stk500 Connection ERROR (Tried all previous post fixes)

I am trying to connect to my arduino after downloading 1.6.5 and can not connect. This is the error I receive from avrdude:

Arduino: 1.6.5 (Windows 8.1), Board: “Arduino Uno”

… all files used shows…

Sketch uses 1,030 bytes (3%) of program storage space. Maximum is 32,256 bytes.

Global variables use 9 bytes (0%) of dynamic memory, leaving 2,039 bytes for local variables. Maximum is 2,048 bytes.

C:\Program Files (x86)\Arduino\hardware\tools\avr/bin/avrdude -CC:\Program Files (x86)\Arduino\hardware\tools\avr/etc/avrdude.conf -v -patmega328p -carduino -PCOM13 -b115200 -D -Uflash:w:C:\Users\SEANMO~1\AppData\Local\Temp\build9096378185190488061.tmp/Blink.cpp.hex:i

avrdude: Version 6.0.1, compiled on Apr 15 2015 at 19:59:58

Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/

Copyright (c) 2007-2009 Joerg Wunsch

System wide configuration file is “C:\Program Files (x86)\Arduino\hardware\tools\avr/etc/avrdude.conf”

Using Port : COM13

Using Programmer : arduino

Overriding Baud Rate : 115200

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x84

… After some time…

avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0x84

avrdude done. Thank you.

Problem uploading to board. See http://www.arduino.cc/en/Guide/Troubleshooting#upload for suggestions.

So I went to the forum and saw that others had this problem and fixed it by doing one of three things:

  1. Make sure you use the right board(Tools>Board>Arduino Uno)
  2. Make sure you are using the right COM Port (Tools>Serial Port> COM13)
  3. Go to device Manager and update/reinstall Driver using Arduino drivers(DID THAT!)

After trying all steps, and some even more out of the ordinary like go into device and change baud rate from 9600 to 115200, it still did not/does not work.

I know it the bootloader is working because(based on the troubleshooting guide) I reset it and the led 13 is on. I know it has power because the power led is on. I know it is connected to the computer because the COM PORT shows up in Device Manager. I have also tried different cables but it still won’t connect.

I am running Windows 8.1, arduino UNO R3, usb connection on com13, Arduino1.6.5, ASUS laptop… don’t know what else to include

I NEED HELP BAD!!! I DON’T KNOW WHAT’S WRONG!!!

Do you have anything connected to pins 0 or 1?

Also when you say you know the bootloader is present because the "L" Led is on, does that mean that it gives the 3 rapid blinks when powered on or reset.

I do not have anything plugged into the board at all(except of course the USB conntector.)

The built in led on Pin 13 is solid when plugin or reset. I assume my bootloader is fine based on a previous forum that said if your led on pin 13 is on then your bootloader is fine.

I am also getting the same error message with my pro mini with different connectors, nothing plugged in and loading blink file.

So I tried loading the bootloader through an isp connection and I get the same error. I feel like the frequency of this problem has gone up based on the newest arduino 1.6.5 update but I could be wrong. There are now a lot of posts about the same problem as mine and they have yet to be resolved.....

Do you think it could be a 1.6.5 bug? If not, what am I doing wrong because I have tried everything I could think of and continue to look for solutions on the forum...

Thanks again to anyone that helps.

I have now tried three different computers:

  1. Acer Windows 7 32 bit LAPTOP
  2. Asus Transformer Windows 8.1 32-bit TABLET
  3. Asus Windows 8.1 Laptop
    I have also tried three different arduino boards:
  4. Arduino UNO R3
  5. Arduino Pro Mini 5V 328P 16MHz
  6. Arduino Pro Mini 3.3V 328P 8MHz
    I have tried two different USB cables/ FTDI connections on each setup and tried all the USB ports on each computer.

All this to say, I am pretty confident this isn’t a board issue…

bump

Uno:

On the Uno, the built-in LED on pin 13 will give a couple of rapid flashes when the reset button is pressed and then released. If it does that, the bootloader is probably Ok.

The next thing to test is one of the sticky posts at the top of this forum is the "Loop-Back Test Instructions".

Pro Mini:

If you have an FTDI adapter plugged into the programming header on the Pro Mini, you can perform the exact same loop-back test.

I am not clear from looking at this entire thread on these 2 questions:

Do you have any working Arduino?

Have any of your Arduinos ever worked?