stk500_getsync() not in sync resp=0x00 error for arduino uno breadboard

Hi ppl,

I recently bought 2 atmega328 with optiboot(told to me by the store) in it. I tried to program it with the setup (this setup is currently what i’m trying to do to bootload). It keep giving me this error.

stk500_getsync() not in sync resp=0x00

Things I tried

  1. I read up the forums and some say to add the 10k resistors to the TX and RX pin which I tried but to no avail.
  2. I tried to bootload with optiloader by Westfield and it failed to bootload too.

I attached my setup there. I hope it’s clear enough.

If it already has optiboot, you don't need to burn the bootloader, they should just work via UART.

How were you wiring them up to the computer?

What tutorial did you follow for the wiring? It just seems that the wiring is kinda odd to me.

From what I can see in the pic:

Uno Breadboard Aref to Avcc or D13 GND to D12 pin13 to D11

Also, do you have the ground and positive reversed on the top side of the breadboard?

If this is just another way of doing it (maybe through programming on the Uno), then I apologize for a wasted post.

@Tom I wired them up as attached. I followed the schematics in this following link.

The site did say that it does not cater to Arduino Uno. Though I did see the same setup on another link that gives the same schematic for Arduino Uno.

I don't have the FT232 and am trying to upload sketches via an arduino uno board w/o microcontroller.

@codlink This setup is based on the bootloading setup in the link

I linked up in the following manner. Uno to Breadboard D13 to D13 D12 to D12 D11 to D11 D10 to Reset

For Breadboard Vcc and ground, Vcc are on the outer lane. Grd on the inner lane.

The rest of the setup of the breadboard is according to this link

Other than the Regulator which I use the one on the Uno and the wiring of the Vcc and Ground, the rest are pretty much from there.

Thanks for the replies! =) If the wiring looks wrong can let me know =)

What voltage do you measure between pins 22 & 20? What is written on the crystal capacitors? It looks like the blue wire going to the crystal may be in the wrong place.



The voltage is 4.94V between pin 20 and 22. What was written on the crystal is 16.000M. The datasheet is as follows:

The blue wire connects X2 to one of the pin of the crystal. The brown wire connects X1 to the other pin of the crystal. Just a question...there's no real differentiation between the pins right...? I don't know about crystals that much...

The picture looks like you've plugged the wires into GND, 13, 12, and 11 on the Uno board instead of 13-10.

Hey thanks for the reply.

The picture is slightly misleading. Because it's meant for bootloading.

The connection for uploading is just the following: D0 to D0 D1 to D1 Reset to Reset 5V to 5V Gnd to Gnd

The rest of the setup is left untouched. Only connection between Uno and breadboard is changed.

The connection for uploading is just the following: D0 to D0 D1 to D1

Try swapping these, it should be tx->rx and vica verca

Edited due to bad advice

No, the OP was correct in connecting TX->TX and RX->RX. The recieve pin on the Arduino board is labelled with reference to the Atmega chip (So arduino RX=USB-TX). In order to use the onboard USB-Serial chip, you need to make sure the same is the case for the breadboard chip.

OP: Did you remove the Atmega chip from the Arduino when you were using it as a USB-Serial converter?

I see, sorry about that.

No, i have never tried to remove the chip, I just connect reset to ground and do a manual reset on the target.

I know the safe way is to upload a empty sketch and use resistors on the tx,rx lines but I must admit that I seldom do that.


No problem about mistakes. I'm also learning! =)

@Tom Yep, I think I connect them accordingly. I have removed the chip from the Arduino. Took me like 20minutes because I was so scared it'll spoil...