stk500_getsync(): not in sync: resp=0x00

Using Win XP and a Arduino Duemilanove that I know worked a year or so ago. Now I get the error above when I try to upload.
Made sure that I am hooked to the correct serial (com port 22)
Made sure I had the right board selected.
Tried two different cables and two different computers with similar results.
Tried hitting reset just before loading.
Computer signals that a usb device has been connected when I connect and the light on the board comes on, but does not flash if I press the reset.
I have read every post I could find related to this error and tried everything I saw with no luck.

Does it sound like my board is belly up? :~


Yes. Nothing was echoed back.

I noticed on one machine, it creates a com 22 when I plug it in. On the other machine, it adds an "Other Devices" and under that a "USB Serial Port" both of which have a question mark indicating a problem. I tried to "reinstall" the drivers and browsed to the *.inf files in the drivers folder and I got "Cannot Install this Hardware"


Arduino Duemilanove ATMEGA328P-PU
FT232R1 datecode 1032 (2010 week 32)
CAN upload with Arduino 1.0

Arduino Duemilanove ATMEGA328P-PU
FT232RL datecode 1138 (2011 week 38)
CANNOT upload with Arduino 1.0
CAN upload with Arduino 0.22

The difference is in FT232R1 & FT232RL.

The same problem occurred after I downloaded the driver from FTDI
Windows 2.08.17(Beta)

Arduino IDE version 0022 upload is working.

kwankunghkg: This sounds right. This was working fine and I had to go away for about a year and a half and returned to a new computer. Reinstalled Arduino and I noticed that the software looked a bit different and wondered if there might be an issue. Where can I get 0022? Is it still out there somewhere?

spycatcher2k: I think you're right about it being the FTDI driver, but I don't seem to know what to do about that because I don't really know what the "right driver" is and where to find it. I also don't know how to change the com port because as soon as I plug the Arduino in, the computer selects com22 and I have not found a way to override that. I am a web developer and I think I hve let hardware get away from me over the years. I am kind of lost on hardware issues any more.

Well, I've dropped back to version 0021 (0022 is corrupt) and the splash screen was what I remembered, but still no luck. I am thinking this thing has given up the ghost.

Not sure where to go from here.

I don't mind getting another. I just don't want to find out the problem was NOT the board and then have the same issue with a new one.

Decisions, Decisions. Adulthood is so damn hard.