stk500_recv(): Programmer not responding , using Macbook Pro Mavericks

Hi all,
I've search on various sites including this one, but I haven't had any luck matching my specific situation to a fix.

setup:
Mac OsX Mavericks (latest update)
Macbook Pro 13" Retina
Arduino 1.0.5 and 1.5.5 both tested
Board: Arduino FIO with FTDI Breakout Board
Loop-Back Test: Works
Sketch: Example Blink Sketch
Correct Port selected

results of upload attempt:

Sketch uses 1,140 bytes (3%) of program storage space. Maximum is 30,720 bytes.
Global variables use 11 bytes (0%) of dynamic memory, leaving 2,037 bytes for local variables. Maximum is 2,048 bytes.
avrdude: stk500_recv(): programmer is not responding
processing.app.debug.RunnerException
	at cc.arduino.packages.uploaders.SerialUploader.uploadUsingPreferences(SerialUploader.java:129)
	at processing.app.Sketch.upload(Sketch.java:1672)
	at processing.app.Sketch.exportApplet(Sketch.java:1578)
	at processing.app.Sketch.exportApplet(Sketch.java:1550)
	at processing.app.Editor$DefaultExportHandler.run(Editor.java:2399)
	at java.lang.Thread.run(Thread.java:695)
Caused by: processing.app.debug.RunnerException: Problem uploading to board.  See http://www.arduino.cc/en/Guide/Troubleshooting#upload for suggestions.
	at cc.arduino.packages.Uploader.executeUploadCommand(Uploader.java:113)
	at cc.arduino.packages.uploaders.SerialUploader.uploadUsingPreferences(SerialUploader.java:127)
	... 5 more

the RX button on the FTDI board flashes when I try to do an upload

I had the same problem with the cable, before I switched to the breakout.
I've tried hitting the reset button in various combinations of upload/button mashing.

I tried to burn a bootloader, but got a similar error.

Forgive me if I've left out some details, happy to provide more.

Any help or advice would be greatly appreciated.

Thanks!

Don

Hi Don,

I had issues uploading with the FIO - just before I went completely crazy I found a solution.
For me it was an issue with Mavericks FTDI driver. I had to disable the current driver with this:

Then install the old drivers:
http://www.ftdichip.com/Drivers/VCP.htm

Then I was able to upload without errors. Hope that helps :slight_smile:

Solution can be found in this post : Arduino in OS X 10.9 Mavericks - Serial Port Issues - Installation & Troubleshooting - Arduino Forum
It works fine

:slight_smile:

Yeah, I was about to go nuts with FIO. Jumped right into programming via XBEE, wasn't working, then tried a usb-serial cable, and still wasn't working!

This sol'n worked great, via both FTDI cable and XBEE S1. Thanks.

Praise Be! Thanks, and so sorry I didn't find the solution myself. Sorry for the dupe. :blush:

Hi all…
I had tried all this methods, but, on my computer still not working.
It was working on the first day I had installed Arduino IDE, but, suddenly stoped to find the correct driver.
Have you got any another idea?
Thanks