STM32 install failure

I am trying to install an STM32 patch for STM32F1 boards in the IDE (1.8.9). I have one for STM32F4 but have been unable to install any others. Several web pages told me to install
http://dan.drown.org/stm32duino/package_STM32duino_index.json
in preferences external board managers but I get a "error downloading" for that url. Same thing for:
http://downloads.arduino.cc/packages/package_index.json
and yet I can browse to both links and both files look ok so not sure why it can't or won't download from or Arduino.cc or install them.

Any suggestions as to how to get STM32F1 boards installed in IDE 1.8.9 for Windows using Windows 7?

Thank you.

This is the error log that I am getting:
Error downloading https://downloads.arduino.cc/packages/package_index.json
java.lang.RuntimeException: java.lang.Exception: Error downloading https://downloads.arduino.cc/packages/package_index.json
at cc.arduino.contributions.packages.ui.ContributionManagerUI.lambda$onUpdatePressed$1(ContributionManagerUI.java:150)
at java.lang.Thread.run(Thread.java:748)
Caused by: java.lang.Exception: Error downloading https://downloads.arduino.cc/packages/package_index.json
at cc.arduino.contributions.DownloadableContributionsDownloader.download(DownloadableContributionsDownloader.java:139)
at cc.arduino.contributions.packages.ContributionInstaller.download(ContributionInstaller.java:333)
at cc.arduino.contributions.packages.ContributionInstaller.downloadIndexAndSignature(ContributionInstaller.java:307)
at cc.arduino.contributions.packages.ContributionInstaller.updateIndex(ContributionInstaller.java:285)
at cc.arduino.contributions.packages.ui.ContributionManagerUI.lambda$onUpdatePressed$1(ContributionManagerUI.java:146)
... 1 more
Caused by: java.nio.file.FileSystemException: C:\Users\Living Room\AppData\Local\Arduino15\package_index.json.tmp: The process cannot access the file because it is being used by another process.

at sun.nio.fs.WindowsException.translateToIOException(WindowsException.java:86)
at sun.nio.fs.WindowsException.rethrowAsIOException(WindowsException.java:97)
at sun.nio.fs.WindowsException.rethrowAsIOException(WindowsException.java:102)
at sun.nio.fs.WindowsFileSystemProvider.implDelete(WindowsFileSystemProvider.java:269)
at sun.nio.fs.AbstractFileSystemProvider.delete(AbstractFileSystemProvider.java:103)
at java.nio.file.Files.delete(Files.java:1126)
at cc.arduino.utils.network.FileDownloader.downloadFile(FileDownloader.java:156)
at cc.arduino.utils.network.FileDownloader.download(FileDownloader.java:132)
at cc.arduino.contributions.DownloadableContributionsDownloader.download(DownloadableContributionsDownloader.java:137)
... 5 more
Error downloading https://downloads.arduino.cc/packages/package_index.json
java.lang.RuntimeException: java.lang.Exception: Error downloading https://downloads.arduino.cc/packages/package_index.json
at cc.arduino.contributions.packages.ui.ContributionManagerUI.lambda$onUpdatePressed$1(ContributionManagerUI.java:150)
at java.lang.Thread.run(Thread.java:748)
Caused by: java.lang.Exception: Error downloading https://downloads.arduino.cc/packages/package_index.json
at cc.arduino.contributions.DownloadableContributionsDownloader.download(DownloadableContributionsDownloader.java:139)
at cc.arduino.contributions.packages.ContributionInstaller.download(ContributionInstaller.java:333)
at cc.arduino.contributions.packages.ContributionInstaller.downloadIndexAndSignature(ContributionInstaller.java:307)
at cc.arduino.contributions.packages.ContributionInstaller.updateIndex(ContributionInstaller.java:285)
at cc.arduino.contributions.packages.ui.ContributionManagerUI.lambda$onUpdatePressed$1(ContributionManagerUI.java:146)
... 1 more
Caused by: java.nio.file.FileSystemException: C:\Users\Living Room\AppData\Local\Arduino15\package_index.json.tmp: The process cannot access the file because it is being used by another process.

at sun.nio.fs.WindowsException.translateToIOException(WindowsException.java:86)
at sun.nio.fs.WindowsException.rethrowAsIOException(WindowsException.java:97)
at sun.nio.fs.WindowsException.rethrowAsIOException(WindowsException.java:102)
at sun.nio.fs.WindowsFileSystemProvider.implDelete(WindowsFileSystemProvider.java:269)
at sun.nio.fs.AbstractFileSystemProvider.delete(AbstractFileSystemProvider.java:103)
at java.nio.file.Files.delete(Files.java:1126)
at cc.arduino.utils.network.FileDownloader.downloadFile(FileDownloader.java:156)
at cc.arduino.utils.network.FileDownloader.download(FileDownloader.java:132)
at cc.arduino.contributions.DownloadableContributionsDownloader.download(DownloadableContributionsDownloader.java:137)
... 5 more

I've deleted your other cross post.

Cross posting is against the rules of the forum. The reason is that duplicate posts can waste the time of the people trying to help. Someone might spend 15 minutes writing a detailed answer on this thread, without knowing that someone else already did the same in the other thread.

Repeated cross posting will result in a suspension from the forum.

In the future, please take some time to pick the forum section that best suits the topic of your question and then only post once to that forum section. This is basic forum etiquette, as explained in the sticky "How to use this forum - please read." post you will find at the top of every forum section. It contains a lot of other useful information. Please read it.

Thanks for your cooperation.

Now I can get to trying to help you out with your problem.

Please try this:

  • In the Arduino IDE, click the link on the line following File > Preferences > More preferences can be edited directly in the file. This will open the Arduino15 (or similar name depending on OS) folder.
  • Delete all files under the Arduino15 folder except for preferences.txt. Please be very careful when deleting things from your computer. When in doubt, back up!
  • Restart the Arduino IDE

Now try the Boards Manager installation again.

pert:
Now I can get to trying to help you out with your problem.

Please try this:

  • In the Arduino IDE, click the link on the line following File > Preferences > More preferences can be edited directly in the file. This will open the Arduino15 (or similar name depending on OS) folder.
  • Delete all files under the Arduino15 folder except for preferences.txt. Please be very careful when deleting things from your computer. When in doubt, back up!
  • Restart the Arduino IDE

Now try the Boards Manager installation again.

I had the same problem when trying to prepare my Arduino IDE to program the Blue Pill dev board, followed this procedure and it worked !!!

Thanks a lot.

You're welcome. I'm glad to hear it's working now. Enjoy!
Per