Strange behavior with power supply vs. computer USB power

I'm debugging a problem with the Seeed music shield v1.0. I'm using an Uno. If I run things off of my computer's USB cable, all things work fine. If I connect a power supply, it can't init the sound card and opening MP3 files fail. I thought my power supply might be bad, so I bought another that outputs more power ( 1 amp). Any ideas on what could be wrong here? It's repeatable 100% of the time. I'm not sure what else to try.

With the power supply plugged into the Arduino, measure the voltage at the Vin pin, what is it?
Measure the 5V pin, what is it?

The Vin is reading 9.1 and the 5V pin on the sound card is at 4.99.

do you have something that supplies 5v over a usb cable? like a small charger? if that worked, it would rule out the powersupply question. its more like a code thing, like hanging on a serial.available() or something

I've now tried 3 different USB chargers. All fail. This is just driving me nuts. As soon as I plug it into the computer, it works.

sounds like a code thing. can you post your code, and which versions of libraries you might be using.

Could it be a code thing if it works when I have it powered by USB? It's works EVERY time if I connect the USB to my mac. If I power it off a DC supply, or a usb power supply, it fails. Every time. So I'm thinking it's not a code issue. But I'm willing to hear why I'm wrong. Could my mac be affecting how the code runs, even if the arduino app is not running? I will try connecting a bigger usb power supply. I've only tried the charger for an iphone, which is low power. I just ordered a 12 watt usb power supply. If that doesn't work, I'm throwing in the towel.

when you plug your arduino into the USB on your computer, you are doing 2 things: 1. giving it 5V power, 2. connecting it to a device that it can talk to. your code is most likely trying to talk to the computer, and when there is no computer connected, it fails, and the program hangs.