strange error

My arduino uno was working fine until I just tried to upload a program. The error message “PORT 4 Is ALREADY BEING USED” appeared. I then reset the arduino, unplugged it, and re- connected it to port 1, this time the error avrdude: stk500_getsync(): not in sync: resp=0x00 appeared, please help,

Do you have any other programs running that are using that port? Occasionally, for some unknown reason I am not able to explain, when I try to upload a new program, it displays "Serial port COM4 not found. Did you select the right one from the Tools > Serial Port menu?". I then plug the usb cable into a different port, and it uploads fine. I have an uno and a nano, and when I accidentally try to upload a uno program to a nano or vice versa, it will tell me it's not in sync, so check that your board matches the one in the Tools > Board menu.

I'm willing to bet you have more than one IDE (Arduino download software) running at a time, and they are conflicting at the USB port. Using the serial monitor and leaving it open might not help either.

Just something to look at.


I tried re-starting my computer, opening one arduino IDE, re-selecting arduino uno, switching cables to a different serial port, (and telling my computer that I did that), resetting my arduino, and never opening the aerial monitor, with no avail. btw, I am using 32bit windows XP

its ok, i solved the problem! :-)

And what was the problem???