Strange issue uploading

I'm using an arduino I built on a breadboard. I've just installed Ubuntu 10.4 and arduino. When I try to upload to my board with an avrisp mkii I get this error

avrdude: stk500_recv(): programmer is not responding

however if I reload th bootloader I can upload code once more. The second and following attempts return the same error. I know my board is ok because it worked on windows. Could this be an issue with the IDE not recognizing my avrisp mkii?

Did you try pressing the reset button right after sending the upload command from the IDE? On my breadboarded units I have to press the reset button about one second after I select File | Upload to I/O board. Any sooner/later and it does not work; I get the same error you get. I haven't tried it with a Windows system, only Ubuntu and Slackware 32/64. I've had good luck since I learned to hit the reset button at the right time.

I've had this problem, but it was with an Atmega8 processor, I put it down to the bootloader (NG or older in the IDE) being incompatible, because the same board and system worked fine using a 168 or 328. I was using Ubuntu 9.10 which made me think when I saw this. I wire up the auto reset and use a USB-TTL convertor with DTR which means I don't need to reset manually.

I'm pretty sure I've tried the reset thing with no results I'll give it another try.

I'm also getting a "programmer is not responding error". I've been searching the net for a while and I can't find a solution.

It works ok on Vista so it's not the hardward or cable.