Strange output of the Board on Serial Monitor

Hi! I'm trying to write a simple "Hello World" program, I'm currently using the STM32L07x/L08x/L010 board(board specs)

Along with ArduinoIDE 1.8.12 I've also installed the STM frameworks to work on Arduino IDE (stm32Duino),
the selected board inside Arduino IDE is:GENERIC STM32L0 SERIES.

Here is the program:

#define debugSerial Serial

void setup()
{
  debugSerial.begin(9600);
}

void loop()
{
  debugSerial.println("Hello world!")
  delay(10000);
}

And here is the compile output:

o sketch usa 13204 byte (6%) dello spazio disponibile per i programmi. Il massimo è 196608 byte.
Le variabili globali usano 1300 byte (6%) di memoria dinamica, lasciando altri 19180 byte liberi per le variabili locali. Il massimo è 20480 byte.
** -------------------------------------------------------------------**
** STM32CubeProgrammer v2.4.0 **
** -------------------------------------------------------------------**
ST-LINK SN : 066BFF383734414D43155352
ST-LINK FW : V2J28M18
Voltage : 3.25V
SWD freq : 4000 KHz
Connect mode: Under Reset
Reset mode : Hardware reset
Device ID : 0x447
Device name : STM32L07x/L08x/L010
Flash size : 192 KBytes
Device type : MCU
Device CPU : Cortex-M0+
Memory Programming ...
Opening and parsing file: thethingsNetwork_prova.ino.bin
** File : thethingsNetwork_prova.ino.bin**
** Size : 13432 Bytes**
** Address : 0x08000000**
Erasing memory corresponding to segment 0:
Erasing internal memory sectors [0 104]
Download in Progress:
File download complete
Time elapsed during download operation: 00:00:01.692
RUNNING Program ...
** Address: : 0x8000000**
Application is running
Start operation achieved successfully

But when I access the output in the serial monitor is:

$$$ 08330221311407180E509E16

Any Idea why?
Thanks

Does your serial monitor baud rate match 9600?