Strange readings from analog pins using potmeter


I've just took out my arduino boards again, and I tought I should start with just the easy Knob tutorial to refresh my arduino skills :stuck_out_tongue:

Anyhow, I've noticed the servo didn't respond like it should. So I put
a serial.print on the reading just to see the value. And it's stuck around 250-300, no matter how I adjust the pot.

So first I changed to another 10k potmeter, same there. Then tried another arduino board. Same there. Also tried changing to another analog pin, but same thing there...

Then I tried the good old Arduino Diecemila(or how its written). Then it read the values perfectly!

Why wont my Picos, Nanos, Boarduino, BareBonesBoard show the correct value from 0-1023 when adjusting the pot? And only the old
diecemila. It's very strange, and I'm very confused right now ....

Cause I wanted the Modified Pico or some other board like the Boarduino to control some servos.

Only the good old arduino diecemila. Thats strange.

I use 5+ and GND for the outer pins, then the center pin I got on analog2.

Picture of the simple wiering on a Modified Pico

Uploaded with

White is center pin, red & black are gnd and 5v

What are those unconnected pins across the top of the board labelled "A0", "A1" etc?


My god, how can I be so stupid :stuck_out_tongue:

I blame the in-activity lately, it's like 5 months since I last used my arduino boards.


Works fine now :stuck_out_tongue: