Strange SD results

I am playing an SD break out that uses the standard SD library, but im having a few issues.

Trying to use the basic example i could not get the card to "initialise".

I then tried the included card info example and that did initialise but "cant find a volume".

So i compared code and found the difference was instead of using SD.begin(). It uses card.init(SPI_HALF_SPEED,6), why is this and more so, why does this one work and the other one not?

Anyway, the card now initialises but no matter what i do i cannot get any further,i have tried to different cards, all Fat combinations and i just cannot get it to open or see a file, even both cards can been seen?

What might i be doing wrong?

Thanks Andy

What are you using to level shift the signal? (SD cards run at 3.3v). Also, are you running the connections through a solderless breadboard?

It sounds very much like you are running the system faster than your connections can handle (too much noise, stray capacitance etc.).