strano comportamento led L

Salve a tutti scrivo questa domanda perché da qualche giorno il led L del mio Arduino uno rev3 si comporta in modo strano quando connetto un led infrarosso al pin 13. in pratica appena do tensione all'Arduino e connetto al pin 13 un led infrarosso il led L ad ogni lampeggio (in questo caso utilizzavo il programma "blink" come test) diminuisce di intensità fino a spegnersi completamente come per un calo di tensione, mentre ad esempio il led di alimentazione rimane inalterato. sono ancora molto inesperto sull'Arduino sia sul codice di programmazione sia sull'hardware, e non vorrei aver fatto danno.

il led L di cui parli lo sai che è collegato al pin 13?

Essendo il tuo primo post e visto l'argomento è evidente che non ti sei presentato nell'apposita sezione e non hai letto il regolamento. Ora subirai le ire di nid69ita. ]:D

Al rogo, al rogo! :D

Se prometti di presentarti Ti do la soluzione:

Devi metter SEMPRE una resistenza in serie al LED per limitare la corrente. Metti una resistenza tra 330 Ohm e 1 kOhm.

Ciao Uwe

llollo96: Salve a tutti

Ti invitiamo a presentarti (dicci quali conoscenze hai di elettronica e di programmazione) qui: Presentazioni e a leggere il regolamento: Regolamento - qui una serie di schede by xxxPighi per i collegamenti elettronici vari: ABC - Arduino Basic Connections - qui le pinout delle varie schede by xxxPighi: Pinout - qui una serie di link [u]generali[/u] utili: Link Utili

grazie per i consigli.
magari per ora prendo uno starter kit e smanetto con quello, almeno sono sicuro di non fare danni

I danni li puoi fare anche con uno starter kit... dipende da cosa fai :grin: