Stuck When Open Arduino IDE

Dear All, Please Help,

When I open the Arduino IDE program, it is very long, after which the program goes out by itself.

I've tried to re-install, but the results are the same.

Does anyone experience the same thing?

thank's for your help.

I have had the same issue. I have had Arduino software running on my Windows 10 PC for quite some time and never had any issues. I haven’t used it for a while. I had a bit of a play about a week ago and was wanting to get back into it today and the program won’t start.

The program starts to launch and then disappears - not even any site of it in the Task Manager. I have read other posts and tried everything - Windows Installer, Windows Zip…

If anyone can help I would greatly appreciate it :slight_smile:

Make sure you are NOT using the windows store APP

Turn of your antivirus or other security just to test. If the test is good then add the IDE locations to your security exclusions / white lists. So that would be at least two of the following.

C:\Program Files (x86)\Arduino C:\Users\yourname\AppData\Local\Arduino15 depends on IDE C:\Users\yourname\AppData\Roaming\Arduino15 depends on IDE

If you have your sketches set up in a different location it’s also worth adding that directory to the exclusions also.

Additionally if you also use the online IDE “CREATE” the following directories. Also ensure that any BROWSER add ons are disabled for CREATE tests !

C:\Users\yourname\AppData\Roaming\ArduinoCreateAgent C:\Users\yourname\AppData.arduino-create

If you have installed to a different drive swap the drive letter as needed. If you also have an unzipped IDE installed that path should also be added to exclusions.

Report back any findings

This is funny.....I just got my software working and thought that I would return to the forum to offer my 2 cents worth. I ended up downloading the App from the Windows App Store and it works. Returning to the forum I see ballscrewbob's post......

I guess when you are in the corner like DEVSEN and myself you are willing to give anything a go :)

Generally those with the “APP” having issues tend to fix it by going to the FULL install package.

Also clean ups of past IDE installations are also generally recommended as they do leave quite a bit behind.