Success! - Vista USB RS232 Emulation Driver Needed

Loaded the Audrino 1.0 software for the Arduino UNO R3 on Windows 7 Home premium Toshiba Laptop with no problem. Plugged in the A to B printer cable and plug installed the necessary drivers. A pop up box came up saying the USB RS232 Emulator Driver was not signed, however started the Array sample, uploaded it to the microprocessor and things worked fine. Blinking lights and all that joy. :)

Not so much luck on my Windows Vista Home Premium SP2 Compaq desktop. :astonished: I don't think the emulator driver was loaded because I get this error:

System wide configuration file is "C:\Program Files\arduino-1.0\hardware/tools/avr/etc/avrdude.conf"

Using Port : \.\COM3 Using Programmer : arduino Overriding Baud Rate : 115200 avrdude: Send: 0 [30] [20] avrdude: Send: 0 [30] [20] avrdude: Send: 0 [30] [20] avrdude: Recv: 0 [30] avrdude: stk500_getsync(): not in sync: resp=0x30

avrdude done. Thank you.

How do I know the USB/RS232 emulation is occuring on my machine? Does anyone know where I can get the driver and install it. This is a big frustration.

Thanks

Mike

Oh yes, baby it works now!! $)

Went online and found the usbser.sys file for Vista. http://www.sysfiles-download.com/sysindex/usbser.sys.html

  1. Renamed old one to usbser_original.sys and copied the new file to c:\windows\system\drivers
  2. Uninstalled Arduino Uno R3 Com device.
  3. Restarted computer and immediately plug and play picked up the Arduino Device...set up to COM5.
  4. Started Aquino 1.0 Software, set up COM5 port on settings, then uploaded the Array program!!

Running with success!! Now I know a bit about the USB RS-232 Emulation Driver and why it is used!!