suddenly disappear /dev/ttyACM0

I have seriously problems with the USB connection with Ubuntu. When I plug the USB cable into the computer the /dev/ttyACM0 appears. A few seconds later it is gone. please help.. thx..

What board are you using?

I use an Arduino uno wifi R3

Disappearing port could be caused by bad cable or bad USB host port. Try other cables and ports. Try the Arduino on another computer to make sure the Arduino is working.

Solved!

I had this problem, with a cheap board marked "Pro Micro" but responding as an Arduino Leonardo. After working well for several days, it started disconnecting after 8 seconds with a laconic "usb 1-5.2: USB disconnect, device number 29" on dmesg.

Other boards were working on the same computer and same cable so I was ready to discard the board but still wondered what I could have done to make it break and wondered at the fact that it still registered for 8 seconds. I suspected it was just a software problem, maybe a partial upload that made it go in a bad state.

So I just uploaded the "blink" program (which is very short) to the board as fast as I could. It requires to connect and upload basically at the same second. That restored my board and I can now reupload my longer program without having it disconnect.

Hey Yves - Thanks for this.

I've been having the same problem with Arduino Leonardo (from Olimex) connected to Ubuntu 18.04: /dev/ttyACM0 appears, but then vanishes after about 5 seconds (confirmed with monitoring "dmesg | grep USB" which shows device installing correctly on plug-in, but then mysteriously disconnecting after a few seconds.

I'd been through all the other threads (removing modemmanager package etc., ensuring I'm part of dialout permissions - all checked and not the problem or solution).

However, I followed your suggestion and, with some holding down of the reset and quick fingerwork, managed after a few tries to force blink onto the board before the port disconnected. Problem solved!

Subsequently I've been able to load my real code without any problems. "dmesg |grep USB" confirms that all necessary loads when the board is connected, and stays there until it is unplugged.

Many thanks!

1 Like

After days of searching net, I stumbled upon your ingenious solution and it worked! The disconnection issue is really bothersome. Thanks a lot.

1 Like

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.