Sunfounder "Arduino Uno Fully Compatible" board problems

I purchased the “SunFounder New Uno R3 Project Super Starter Kit For Arduino UNO R3 Mega2560 Mega328 Nano”. The first two sketches I tried had problems:

  1. Standard Blink didn’t blink, just lit the LED attached to pin 13. Adding a resistor to ground from digital pin 13 fixed this – LED on board then blinked as expected.

  2. OmniWheelControl sketch from Make Magazine “reset” as soon as a “pulseIn” command was executed. Upon the “reset”, the setup(); section re-executed, followed by the portion of the loop(); section up to the first “pulseIn” command. This sequence repeated rapidly. The reset appears to be the same thing that happens when the reset button is pushed – the program starts over from the top. Replacing the Sunfounder “Arduino” with a real Arduino fixes the problem 100%.

Do I have a bad unit, or do all Sunfounder boards have these problems? Searching didn’t uncover anyone else having these issues. Thanks.

Bob Walton

If it is advertised as "Arduino UNO fully compatible" then it is obviously faulty because Blink works on an Arduino UNO and every clone I've ever tried.

Followup on my original post: I contacted SunFounder, and they replaced the defective board. The replacement board seems to be fine. So I guess I just had an unlucky one-off problem.

Bob Walton