Suspect 1st Problem is I bought a cheap clone... LOL

Hi Guys…

I have an associate degree in Electronics that I received when I first got out of school (15 years ago!)… but I never put it to real use because I went into IT (Computer Repair). Anyways I always was interested in the ARDUINO micro controllers but as I am injured and unemployed I couldn’t really afford the kits. When I saw that I could get one from china direct for a couple of bucks I jumped on it. Thinking back on it I always advised my clients NOT to do this; BECAUSE you will spend more time trying to solve stupid issues and TIME is money (indirectly). Knowing this I bought TWO of them, LOL. Stupid, eh?

In my defense I have ordered other items thru the website and rarely had any problems…

Having said that, I SUSPECT I have a LEMON on my hands, but I am also out of my area of expertise so I thought I would consult with some experts before I put anymore energy into it one way or another. Perhaps if I document this well I can help the poor sucker who followed my mistake or better yet keep another from buying one in the first place.

Here is a couple things I noticed that had me scratching my head … I will put #'s to them so should you respond you can tag it with the #.

#1 Driver issues and Documentation. < SOLVED!

Clones have plenty of DRIVER ISSUES … And NO Documentation.

After banging my head on the wall for a while, I figured out that my Uno board uses a “odd driver”…
You guys helped me solve that indirectly by posting the solution for another user. Thank you!

http://www.winchiphead.com/download/CH341/CH341SER.ZIP

I bought a couple accessories and again if it wasn’t for other sites documentation I would be dead in the water. They don’t even label the packages.


# 2 Unable to consistently upload sketches to my uno…

From the start with Blink and the like I would get odd AVRDUDE errors. I just hit upload again and usually I could get around it. BUT I would think that is an indicator of a more serious issue. This proved to be true, when I started playing with more complicated and larger sketches I could no longer get around it. I was working on a RFID project when I figured out that it wasn’t me.

To isolate it, I tried uploading the “Bare min” example to my Uno alone. To my knowledge you can’t get any more basic then that - nor should you have ANY issues (Right?). That said my clone will randomly fail to do so. The code is always as follows; except the byte address constantly changes.
avrdude: verification error, first mismatch at byte 0x0119.

To me this is a SHOWSTOPPER and I have no ideas how to fix it, besides the obvious and buy a quality board. I did the silly stuff to verify the results and reloaded both the drivers and the IDE software and I consistently bomb out roughly every third time using the “Bare Min” example. Again, it is inconsistant at best, doing the smallest of jobs.

Any ideas or constructive comments welcome. I already beat myself up on my silly purchase.

-misj-

I tried the loopback test and that seemed to fail as well. My understanding is that if I type something in serial monitor it will be "echoed" and displayed in the window at the bottom. None of my replies are echoed. I tied a second shorter USB as well.

-misj-

Dang! You guys are GOOD!

In trying the loopback test I switched out the USB cable for a shorter one ... AND Poof many of my problems went away. At the very least I can now do the "Bare Min" sketch without it blowing up in my face!

Still can't successfully do a loop back test though which is odd. Thanks for the help!

-misj-

I have the strange feeling I will be back. LOL