taskaction library doesnt function SOLVED

Hi ALL; I downloaded, copied and pasted the zip files in my libraries folder, restarted the IDE but Arduino doesnt recognize it. It doesnt show up when I hit add zip. I decompressed it and as the files didnt have the cpp or h ext I added them but didnt help. Any link to working library? Thanks.
Just in case, WIN7, v1.6.11.

alah:
as the files didnt have the cpp or h ext I added them but didnt help.

By default Windows hides file extensions, so they may have been there all along. You probably have files named things like name.h.h and name.cpp.cpp now. There’s a way to set it to show the file extensions, but I don’t know where it is. I’m sure google knows.

Post a link to where you downloaded this library from. Please use the chain links icon on the toolbar to make links clickable whenever you post them on the forum.

From the Playground page:
https://playground.arduino.cc/Code/TaskAction

Click on the "stable release" link to download the TaskAction.rar file.
https://github.com/blackhack/ArduLibraries/blob/master/Releases/TaskAction.rar?raw=true

Move the TaskAction.rar file to the 'libraries' directory inside your sketch directory.

Double-click on the archive to expand it into a directory called TaskAction in your 'libraries' directory.

Re-start the Arduino IDE.

You should now find the example sketches in File->Examples->TaskAction.

(Works fine for me in Arduino 1.8.2. If it fails for you it might be time to update your Arduino installation.)

HI, I did get to github but all I could do was download the files , pastes them in a folder, tried, compressed the folder, still didnt work. Just did as wasser suggested so now I have zip packet. Will try as soon as i get home. I do have v1.8.3 but I wanted to solve this first. Will get back, for the moment if it works, how can I close this topic, if I should? Thanks.

alah:
how can I close this topic, if I should?

It's very helpful to mark your topic as solved. From http://forum.arduino.cc/index.php?topic=148850.0:

If you consider the issue solved, please edit your original post (the first one in the thread) and add "[solved]" to the subject line. That helps people know the issue is resolved.

Thanks!

SOLVED! I follwed Wasser´s suggestion although I remember having read somewhere that one shouldn´t expand the zip files, maybe an older version?
I would have never guessed to how to ay SOLVED, hope its correct. THANKS to all.