TB6600 and grbl problem!

Hi everyone!

I've recently finished building my cnc machine. At first I was using CNC shield with A4988 drivers, but they were overheating, so I've decided to change them to TB6600 drivers.

Unfortunately after changing drivers, my steppers don't work with grbl loaded. I’m currently using:

  • Arduino UNO

  • 24V 10A PSU

  • GRBL 1.1h

  • NEMA17 2A

I've tried both common cathode and common anode connection, but neither worked. What's even more interesting, when I load example sketch: stepper_oneRevolution and set everything as needed, motors are working without any problems. When I try to move stepper motors using UGS, nothing happens except for audible click. Drivers also are enabled, because I can not move motors by hand. I've searched for solution for hours, but I couldn’t find anything useful.
Can someone help solve my problem?

Check your wiring against the wiring in this link. User is using the TB6600 drivers and GRBL.
Arduino GRBL and TB6600

I'm using the A4988 drivers equipped with heatsinks and a little fan! No problem then.
Searching for hours? I had to spend a hole year to find out the fault, redesigning boards, software..... Hours..... You need Santa Claus.
I've also used the 6600 without any difficulty.

If You had done Your home work You would have used the first topic telling how to get the best from this forum.

How on earth do You think any helper could pin point the reason for Your issue out of what You tell? Please send us crystal balls.....
or a proper wiring and code.....

I've used this diagram, luckily I've found the main problem. When I was rechecking connections, I realized that I've made mistake in Tb6600 connection. To be more specific, I wrongly connected step and dir and now everything works fine.
Thanks for help.