TCA9548A I2C Multiplexer

Hello, I just recently bought a TCA9548 Multiplexer. I followed the instructions on the adafruit website: Link When It wasn't working, I tried the Adafruit forums. But they said,

Looks like you are using an Arduino 101. That has an Intel Curie processor & I would not be surprised if there are substantial differences in the i2c support for it. You might try posting your question over on the forums. They are the ones that maintain the libraries for the 101.

So, what should I do?

Hi and welcome to the forum.

You could perhaps read this.

I know.
Here is my code:

 * TCA9548 I2CScanner.pde -- I2C bus scanner for Arduino
 * Based on code c. 2009, Tod E. Kurt,

#include "Wire.h"
extern "C" { 
#include "utility/twi.h"  // from Wire library, so we can do bus scanning

#define TCAADDR 0x70

void tcaselect(uint8_t i) {
  if (i > 7) return;
  Wire.write(1 << i);

// standard Arduino setup()
void setup()
    while (!Serial);

    Serial.println("\nTCAScanner ready!");
    for (uint8_t t=0; t<8; t++) {
      Serial.print("TCA Port #"); Serial.println(t);

      for (uint8_t addr = 0; addr<=127; addr++) {
        if (addr == TCAADDR) continue;
        uint8_t data;
        if (! twi_writeTo(addr, &data, 0, 1, 1)) {
           Serial.print("Found I2C 0x");  Serial.println(addr,HEX);

void loop() 

Here is my error:

Arduino: 1.8.5 (Windows 8.1), Board: "Arduino/Genuino 101"
IC:\Users\user\AppData\Local\Arduino15\packages\Intel\hardware\arc32\1.0.7\system/libarc32_arduino101/framework/include"  "-IC:\Users\user\AppData\Local\Arduino15\packages\Intel\hardware\arc32\1.0.7\cores\arduino" "-IC:\Users\user\AppData\Local\Arduino15\packages\Intel\hardware\arc32\1.0.7\variants\arduino_101" "-IC:\Users\user\AppData\Local\Arduino15\packages\Intel\hardware\arc32\1.0.7\libraries\Wire\src" "C:\Users\user\AppData\Local\Temp\arduino_build_997323\sketch\TCA9548A.ino.cpp" -o "C:\Users\user\AppData\Local\Temp\arduino_build_997323\preproc\ctags_target_for_gcc_minus_e.cpp"
C:\Users\user\Documents\Arduino\TCA9548A\TCA9548A.ino:10:74: fatal error: utility/twi.h: No such file or directory

 #include "utility/twi.h"  // from Wire library, so we can do bus scanning


compilation terminated.

Using library Wire at version 1.0 in folder: C:\Users\user\AppData\Local\Arduino15\packages\Intel\hardware\arc32\1.0.7\libraries\Wire 
exit status 1
Error compiling for board Arduino/Genuino 101.

Maybe this?

fatal error: utility/twi.h: No such file or directory

Please use an up to date I2C scanner as this seems rather old

Check -

or my multispeed one -

Okay. Now, the code seems to be okay when I replaced it with arduino's code. I tried test plugging some sensors in, and I got:

No I2C devices found

I2C device found at address 0x70  !

It would keep repeating this pattern.