téléversement pour un arduino uno uniquement possible en uno atmega 328p

bonjour, j'ai acheté un arduino chinois récemment car mon arduino m'a laché.
le problème c'est que j'ai ce message d'erreur quand je téléverse en mettant comme type de carte "arduino uno"

avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0xdc

du coup j'ai vu sur des forums qu'on pouvait mettre comme type de carte "arduino nano" avec Atmega 328p (old bootloader) comme processeur et là ça marche.

mais quand je téléverse comme ça les programmes fonctionnent partiellement ou pas du tout.

donc si vous avez des idées de où ca pourrait venir, perso j'y connais pas grand chose je bidouille juste un peu .
merci d'avance

mais quand je téléverse comme ça les programmes fonctionnent partiellement ou pas du tout.

et ça vient pas de votre code ? :slight_smile:

est-ce que blink fonctionne ?

avez vous un autre arduino qui fonctionne?
vous pourriez mettre à jour le bootloader de cet arduino bizarre...

timodre:
bonjour, j'ai acheté un arduino chinois récemment car mon arduino m'a laché.
le problème c'est que j'ai ce message d'erreur quand je téléverse en mettant comme type de carte "arduino uno"

avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0xdc

du coup j'ai vu sur des forums qu'on pouvait mettre comme type de carte "arduino nano" avec Atmega 328p (old bootloader) comme processeur et là ça marche.

mais quand je téléverse comme ça les programmes fonctionnent partiellement ou pas du tout.

donc si vous avez des idées de où ca pourrait venir, perso j'y connais pas grand chose je bidouille juste un peu .
merci d'avance

bonjour
symptomes etonnants
le uno "asia" est monté avec un mcu 328p en package DIP ou TQFT32 ?

Si la UNO se téléverse correctement avec comme type de carte "arduino nano" et "Atmega 328p (old bootloader)" c'est qu'elle contient un old bootloader de NANO.

mais quand je téléverse comme ça les programmes fonctionnent partiellement ou pas du tout.

Ce qui est étonnant, étant donné que le processeur est le même.

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.