Termistore 4.7K Kit Arduino

Ciao a tutti! Sono appena entrato nel mondo Arduino e oggi ho fatto qualche progetto di prova,ma già sono spuntati i primi dubbi!:) Volevo provare a fare un semplice termometro usando un termistore,ma quando utilizzo la formula: R =Ro exp(–Beta/(T +273) -Beta/(To +273) Non so trovare Beta perchè non riesco a trovare il datasheet del mio termistore :( Qualcuno sa dove posso cercare il datasheet del termistore(ma anche degli altri componenti se mi dovessero servire)? Già che ci sono chiedo subito se qualcuno sa anche consigliarmi qualche progetto carino per principianti:) Grazie mille in anticipo!:)

Se ci dici il modello del termistore oppure ci fai una foto oppure ci dici dove l'hai comprato (se online) allora ti potremmo aiutare. Per tutto il resto -->> http://arduino.cc/forum/index.php/topic,91560.0.html

Il termistore è quello di questo starter kit:http://store.arduino.cc/it/index.php?main_page=product_info&cPath=2&products_id=81 Nelle info dice 4,7K Ohm Thermistor,ma io non ho trovato altro,nel caso se clicchi sul link c'è una foto con tutti i componenti:) Grazie mille anche se credo di aver violato almeno una decina di regole :D

Ho trovato una discussione sullo stesso argomento --> http://arduino.cc/forum/index.php?topic=52462.0

Cambia il titolo del primo topic in qualcosa tipo: "Termistore 4.7K Kit Arduino". ;)

Grazie!

attualmente hai 3 incognite: T, T0 e beta.
Quindi se fai 2 misurazioni a 2 differenti temperature note (magari una appoggiando il termistore sul ghiaccio e una a temperatura ambiente) hai da trovare solo beta.
buona matematica :grin:

Dopo qualche calcolo e un po’ di pazienza sono riuscito a farlo funzionare correttamente,grazie mille per gli aiuti!:slight_smile:
Solo un dubbio mi rimane:la resistenza segnata sul termistore(4,7kOhm) non dovrebbe essere la resistenza del termistore a 25 gradi celsius?Perchè usando questi dati(T0=25 e R0=4700) e la temperatura e resistenza misurati da me(T=36.7 e R=4367) svolgendo i vari calcoli trovo un Beta sbagliato,nel senso che quando provo a calcolare la temperatura non mi esce corretta,mentre dopo quando ho usato due temperature diverse misurate da me fila tutto liscio e funziona.

Domandina: Sul termistore c'è scritto 103 o 470?

Sul termistore c'è scritto 4k7 che io ho interpretato come 4,7k ohm,comunque questa è una foto: http://www.varesano.net/files/thermistor.jpg

Si, è da 4,7k ohm. :grin: E la resistenza del termistore dovrebbe essere quella a 25°.

Toglimi una curiosità? Per misurare 36,7° hai messo il termistore con un termometro sotto l'ascella? :roll_eyes:

  1. che valori stai usando per fare il partitore di tensione (se lo fai)
  2. come fai a trovare una retta con un solo punto (un punto è dato da t e r)

PaoloP:
Si, è da 4,7k ohm. :grin:
E la resistenza del termistore dovrebbe essere quella a 25°.

Toglimi una curiosità? Per misurare 36,7° hai messo il termistore con un termometro sotto l’ascella? :roll_eyes:

Per misurare 36,7° ho misurato con un termometro la temperatura che c’era tra pollice e indice e poi ho stretto il termistore con pollice e indice,sicuramente non è il top della precisione però in qualche modo ha funzionato:)

lesto:

  1. che valori stai usando per fare il partitore di tensione (se lo fai)
  2. come fai a trovare una retta con un solo punto (un punto è dato da t e r)

Il partitore di tensione lo faccio con il termistore e con un resistore da 10kOhm,mentre per trovare i valori di cui avevo bisogno ho usato l’equazione di Steinhart-Hart con parametro B(http://it.wikipedia.org/wiki/Termistore#Equazione_con_parametro_B):
1/T=1/T0+(1/B)ln(R/R0)
in cui ho misurato T e T0 e trovato le relative resistenze;dopo aver trovato B con quest’altra equazione ho trovato rinf:
rinf=R0 e^(-B/T0)
e con B e rinf ho potuto usare questa formula per trovare la temperatura:
T=B/ln(R/rinf

ah, ok , hai preso due misurazioni, non una sola.. una è T=36.7 e R=4367, c'altra qual'è?

Allora: T1=36,7°C R1=4367 Ohm T2=24°C R2=5060 Ohm poi in teoria ci sarebbe anche quella dei 4700 Ohm a 25°C ma se uso questa il termometro poi è sballato..

non è che hai invertoto la resistenza e il termistore?

in teoria a 25° dovresti leggere 1.59v, 3.4v se hai sbagliato i collegamenti

A 24°C leggo 3,32V..I volt li ottengo così:V=(5.0*lettura)/1024; E la resistenza la ottengo così:R=((10000*5.0)/V)-10000; Il circuito comunque è questo: https://www.dropbox.com/s/cdy3f7h06g1asqy/termo.JPG Il filo Giallo si collega al pin A0,il filo rosso a GND e il filo verde a 5V. Con questo circuito e le costanti ricavate dai calcoli prima funziona:)

La resistenza mi sembra sulla riga sbagliata. :roll_eyes: 27 invece che 26.

PaoloP: La resistenza mi sembra sulla riga sbagliata. :roll_eyes: 27 invece che 26.

Uhm. è vero

Si anche a me vedendo la foto,ma ho ricontrollato ed è sulla riga giusta:)

bho a questo punto mi viene da dire che o la R da 10k o la termoresistenza è starata