Test 7-segment contrarié par "cathode commune"

Bonjour,
J'ai suivi ce tuto Redirection vers Afficheurs 7 segments
et ce branchement http://eskimon.fr/wp-content/uploads/tuto/342836.png qui était censé me faire "briller" mes 7 segments
sans aucune programmation si j'ai tout compris, juste brancher la carte Arduino Uno.

Comme rien ne se passait et après avoir contrôlé mon circuit, mesurer la tension (+5V DC) etc.
Je me suis penché sur le 7-segment en question et je me suis rendu compte qu'il est à cathode commune
et non pas à anode commune (c'est un 5011AH). Bon ... j'ai déjà signalé d'entrée de jeu sur le forum que je ne suis pas une lumière en branchement :o ...
Dans mon cas quoi faire au plus simple, à votre avis, compte tenu de ce schéma
http://eskimon.fr/wp-content/uploads/tuto/342836.png
pour que la lumière soit ?

Mille Merci pour vos réponses ... je sais je sais je démarre ... mais j'ai pas envie de tout cramer aussi :wink: même des éléments à 50 cents ...

Laurent

Bonjour,

Tu mets le point commun qui est actuellement au 5V au GND.
Dans ton programme pour allumer tes segments il faudra mettre tes sorties à HIGH alors qu'avec les anodes communes il fallait les mettre à LOW.

Hello Kamill,

  1. Donc sans rien toucher, il me suffit de programmer les sorties à High et ça va s'allumer ?

  2. Sinon si j'inverse le 5V et le GND sur la carte Arduino comme ceci ?


ça fonctionnerait ?

C'est quoi le plus propre 1) ou un changement de câblage type 2)

le cas 1) c'est le cas ou tu pilotes par l'arduino. Il faut changer le 5V par GND

le cas 2) c'est le cas ou tu allumes tout les segments sans programme. Oui il faut inverser 5V et GND comme sur ton schéma. Par contre si tu utilises du fil rouge pour la masse et noir pour le 5V tu risques de te tromper à plus ou moins courte échéance.

MERCI Kamill !

Parfait le cas 2) fonctionne parfaitement
Oui je ne voulais pas alourdir ma prose mais le rouge pour la masse, ça me heurte aussi,
c'est juste pour ce test !?

Je vais faire un test maintenant par programme pour le cas 1)

Au passage ... pour défaire et refaire les branchements, à part déconnecter la prise usb/Arduino, le
temps des manipulations puis rebrancher il n'y a pas de déconnexion/connexion logiciel possible ?

Content que ça fonctionne.

Pour les manips, personnellement j'utilise un hub usb avec des switches comme celui ci:

C'est super pratique

Un hub à interrupteur, première fois que je vois ça ... effectivement un achat envisageable !?