TFT 3.2" QVT ILI9341 touch doesn't work

I've recently bought a package (Package info), including the following items

  • Arduino Mega 2560
  • TFT LCD Mega Shield V2.2 (40 pin)
  • 3.2" TFT (tft_320qvt_9341)

I downloaded the necessary libraries (UTFT, RTouch), and tried with the RTouch Calibration. After changing the tft init line to

UTFT myGLCD(ILI9341_16,38,39,40,41)

the picture was good, aligned to edges. BUT, touch does not work.

I used the following code (even tried with different pins):

UTouch myTouch(6,5,4,3,2);

but no success. According to the documentations and datasheets, it supposed to be ok, but I couldn't get it work :frowning: I've found a very similar topic (LINK), without solution :frowning: It is almost 2-year-old, hopefully someone has an idea since then.

Perhaps faulty, I have that screen and it works fine.

G

I am having similar problem. I ran the TOUCH_AS_EXAMPLE and it appears that my touch screen is functioning properly but when I load my project then touch doesn't work properly. I also found that when run my project with serial window open, the x and y coordinates were being detected as -1.

Try the TOUCH_AS_EXAMPLE script and see what you get.

ghlawrence2000:
Perhaps faulty, I have that screen and it works fine.

G

Good to hear that, then there is still hope :slight_smile: Did you have to change anything in UTFT's or URTouch's code? Do you use the same init lines what I mentioned?