TFT becomes pixelated and goes white

I have been working with a variety of TFTs as of late from different suppliers from 2.4" to 7". I have an issue with a current set up that just has me puzzled. Base info: Mega 2560 R3 IDE 1.0.1 Sainsmart TFT mega shield V1.0 (elecfreaks is the same board as far a pins and resistors, but better documents)

and a 4.3 inch TFT

I use a pot to reduce VCC to 3.3volts.

I generally begin with the UTFT library and for the SSD1963 use the Demo 480x272 UTFT myGLCD(ITDB43,38,39,40,41);. I understand this is not a named supported display but the SSD1963 is supported in the screen size. It is possible my initialization should be different?

The odd behavior: When powered via USB or wallwart the screen performs the clr.scrn command, visually wiping the screen left to right, occasionally it will show the sine wave of the demo, and then the screen develops white lines that run through the screen vertically then, slowly (4 seconds) fades to white. I have chased all connections down and appears everything should be ok. Hoping one of you TFT gurus have ran into something like this before.

Thanks, B

I'm new with the arduino, but one comment you made in your post seems odd.

I use a pot to reduce VCC to 3.3v

Do you mean that a pot is your method of reducing 5v to 3.3v? ... Or is the pot controlling some king of regulator? If the former, I'd be surprised if it worked very well. Bernie

That sort of fading is due to the driver chip stopping driving the display - each pixel's capacitance then slowly discharges and every pixel fades (dependent on variations between pixels and the last voltage it held).

Using a pot (as a potential divider) to provide a power rail is flawed - the voltage then will vary as the instantaneous current demand from the driver varies, providing a very poor supply (unless bolstered with large decoupling capacitor).

It may also be that the device needs 5V, 3.3 is not enough?

I've had a poke about in the datasheets and something looks fishy: the TFT screen itself wants 3.3V, the adapter shield seems not to have a voltage regulator (and is passing +5V to the TFT? Or maybe 3.3V to the LED backlight? Anyway it doesn't seem to make sense to me, or the schematic is the wrong one? If the adapter shield is passing the Mega's 3.3V supply direct to the TFT this could be an issue as the 3.3V supply isn't as beefy as the 5V supply on Arduinos - it might not be enough.

berniew- Yes it is in-line for the power. To expand it is a bournes trimmer resistor with a cap.

MarkT- The confusion has been the case for me as well. There is no regulator obvious on the board, like with the Itead products, not for the VCC that is. It is pretty funny that the library will tell you to put 5v to Vcc but the company puts in RED do not apply 5V. I am pretty sure you have nailed down the problem. Last night I pulled VCC back to 2.10 volts and the program actually ran for almost two full seconds and this was repeatable. Note: not 2.9 not 2.11, but 2.10. I can watch what you describe happening, the program will run a pixel will pop up things slow down and this goes till the screen goes white.

I have made the assumption the load would be constant when powered up. This might be the issue, I will attempt to build a better 3.3v power supply today. Another thing noted was the shields bourns trimmer does not change the backlight. I adjusted it from 3.3v to 1.2v and nothing changed wth backlight. If I had not chased down every connection I would think the diagram was wrong.

Thanks guys!

First of all I would like to clarify a couple of things:

  1. VCC should be connected directly to 5v. (Ref: ElecFreaks Wiki: Pant and Touch Code → Connect the power pins : LCD-A to 3.3V , VCC to 5V , GND to GND)

It is pretty funny that the library will tell you to put 5v to Vcc but the company puts in RED do not apply 5V.

The red text (I assume that you are refering to the red text on the ElecFreaks Wiki page) does not regard Vcc. The 3.3v signal level they are refering to is the voltage level of the I/O pins.

Then over to the originally posted issue:
I had the same problems when I added support for the ITead 4.3" and 5.0" displays to UTFT. I was originally using a shield that used resistors for level shifting. I could not figure out what was wrong.
Then I got the newer shields from ITead with the ICs instead of resistors. Then everything magically worked :slight_smile: It would seem to me that the SSD1963 is not as tolerant as most other TFT controllers with regards to the I/O voltage levels.
This may be the issue with the ElecFreaks 4.3" display as well, but as I do not have one I cannot verify this (which is also the reason it is not listed in the supported displays list).


Doc I noticed the ITead ICs and the other shield's resistors.

It would appear my assumption of constant amp draw, based on the shield, extended much further. I will make the shield swap. One of my first "larger" TFTs was the sainsmart 3.2 I have used the shield on a few other drivers with success but your response helps me to better understand SSD1963.

Can I expect this chip is fried? I know all the resistors on the TFT board are good might start checking caps... (this is only because I am looking for an excuse to build this :P). If the load was reduced on one of the data lines and it reached over 3.3, max possible 4.7 I think, would this kill the SSd1963?

As a side note. [u]A huge thank you for the UTFT!!![/u]

997_1: Can I expect this chip is fried?

I wouldn't think so. I used the old ITead shields (resistor-based) for many hours on the 4.3" and 5.0" modules (without much luck), yet the display modules were not damaged at all.