TFT keeps showing just white

Hi,

First of all, I’m a complete newbie with arduino, so I may be doing things just plain wrong. I have a 4.3" inch TFT LCD screen that I’m connecting to a CTE shield, and this to an Arduino DUE R3.

I first tried to execute some examples. Some of them use the UTFT_CTE library, but there seems to be a couple of functions, namely _SPIread and _SPIwrite), that do not work (note that the SPI library does not include these).

So I decided to use just the UTFT library and I changed the port configuration as stated in the CTE help document:

UTFT myGLCD(CTE50,25,26,27,28);

It compiles and allows to upload it to the arduino, but the screen won’t show anything.

As a first program I decided to try with this:

#include <UTFT.h>
UTFT myGLCD(CTE50,25,26,27,28);

extern uint8_t SmallFont[];


void setup() {
  myGLCD.InitLCD();
  myGLCD.clrScr();
  myGLCD.setBackColor(0,0,0);
  myGLCD.setFont(SmallFont);
  myGLCD.print("Hi", CENTER,10);
  // put your setup code here, to run once:

}

void loop() {
  // put your main code here, to run repeatedly:

}

Thank you very much in advance

Hi Victor,

The most likely problem is you didn't uncomment line 4 of \libraries\UTFT\hardware\arm\HW_ARM_defines.h

#define CTE_DUE_SHIELD 1

Regards,

Graham

Hi Graham,

Thank you for your response. Actually, it was uncommented, so I don't now what it can be :confused: .

By the way, what happened with the CTE library? You seem to know about it, were they going to release a new one and finally they didn't?

victormv99:
I have a 4.3" inch TFT LCD screen that I'm connecting to a CTE shield, and this to an Arduino DUE R3.

Can you confirm WHAT size display you have? Is it 4.3" or 5.0" ??

Graham

victormv99

Make sure the pins are connected all the way in, I know it sounds like a dumb answer, but trust me I had the same problem you did, connected the pins all the way in and, boom, demo worked perfectly.