TFT LCD Compile error

Hi I have just bought this TFT LCD screen for my arduino http://www.ebay.co.uk/itm/360789546290?ssPageName=STRK:MEWNX:IT&_trksid=p3984.m1497.l2649

I'm using Arduino IDE 1.0.5 and I have tried 1.0.4 My Arduino is Arduino UNO REV 3

I'm having lots of trouble compiling the code that it came with on disc This is my error list, as you can see its pretty big lol, if anyone can help me figure out whats going wrong id very much appreciate it as I want to get this working lol.

I have uploaded the code that was supplied with the TFT LCD

https://skydrive.live.com/redir?resid=6CEE75E6BACD34E0!8036&authkey=!ABXudHTTTQEZcQY&ithint=file%2c.rar The zip file is named uno 2.6

I had to cut some of the errors out here, as I exceeded the limit of characters to post.

In file included from graphicstest.pde:18:
C:\Users\Ashley\Downloads\arduino-1.0.5-windows\arduino-1.0.5\libraries\TFTLCD/TFTLCD.h:138: error: 'uint8_t' does not name a type
C:\Users\Ashley\Downloads\arduino-1.0.5-windows\arduino-1.0.5\libraries\TFTLCD/TFTLCD.h:140: error: 'uint8_t' does not name a type
C:\Users\Ashley\Downloads\arduino-1.0.5-windows\arduino-1.0.5\libraries\TFTLCD/TFTLCD.h:141: error: 'uint8_t' does not name a type
C:\Users\Ashley\Downloads\arduino-1.0.5-windows\arduino-1.0.5\libraries\TFTLCD/TFTLCD.h:143: error: 'uint16_t' does not name a type
C:\Users\Ashley\Downloads\arduino-1.0.5-windows\arduino-1.0.5\libraries\TFTLCD/TFTLCD.h:144: error: 'uint8_t' does not name a type
C:\Users\Ashley\Downloads\arduino-1.0.5-windows\arduino-1.0.5\libraries\TFTLCD/TFTLCD.h:145: error: 'uint16_t' does not name a type
C:\Users\Ashley\Downloads\arduino-1.0.5-windows\arduino-1.0.5\libraries\TFTLCD/TFTLCD.h:146: error: 'uint16_t' does not name a type
C:\Users\Ashley\Downloads\arduino-1.0.5-windows\arduino-1.0.5\libraries\TFTLCD/TFTLCD.h:147: error: 'uint8_t' does not name a type
graphicstest:20: error: no matching function for call to 'TFTLCD::TFTLCD(const uint8_t&, const uint8_t&, const uint8_t&, const uint8_t&, const uint8_t&)'
C:\Users\Ashley\Downloads\arduino-1.0.5-windows\arduino-1.0.5\libraries\TFTLCD/TFTLCD.h:65: note: candidates are: TFTLCD::TFTLCD()
C:\Users\Ashley\Downloads\arduino-1.0.5-windows\arduino-1.0.5\libraries\TFTLCD/TFTLCD.h:65: note:                 TFTLCD::TFTLCD(const TFTLCD&)
graphicstest.pde: In function 'void testFillRoundRect()':
graphicstest:121: error: 'class TFTLCD' has no member named 'println'
graphicstest:123: error: 'class TFTLCD' has no member named 'println'
graphicstest:125: error: 'class TFTLCD' has no member named 'println'
graphicstest.pde: In function 'void testfillcircles(uint8_t, uint16_t)':
graphicstest:129: error: 'class TFTLCD' has no member named 'width'
graphicstest:130: error: 'class TFTLCD' has no member named 'height'
graphicstest.pde: In function 'void testdrawcircles(uint8_t, uint16_t)':
graphicstest:137: error: 'class TFTLCD' has no member named 'width'
graphicstest:138: error: 'class TFTLCD' has no member named 'height'
graphicstest.pde: In function 'void testfillrects(uint16_t, uint16_t)':
graphicstest:147: error: 'class TFTLCD' has no member named 'width'
graphicstest:149: error: 'class TFTLCD' has no member named 'width'
graphicstest:149: error: 'class TFTLCD' has no member named 'height'
graphicstest:150: error: 'class TFTLCD' has no member named 'width'
graphicstest:150: error: 'class TFTLCD' has no member named 'height'
graphicstest.pde: In function 'void testdrawrects(uint16_t)':
graphicstest:156: error: 'class TFTLCD' has no member named 'width'
graphicstest:157: error: 'class TFTLCD' has no member named 'width'
graphicstest:157: error: 'class TFTLCD' has no member named 'height'
graphicstest.pde: In function 'void testfastlines(uint16_t, uint16_t)':
graphicstest:163: error: 'class TFTLCD' has no member named 'height'
graphicstest:164: error: 'class TFTLCD' has no member named 'width'
graphicstest:166: error: 'class TFTLCD' has no member named 'width'
graphicstest:167: error: 'class TFTLCD' has no member named 'height'
graphicstest.pde: In function 'void testlines(uint16_t)':
graphicstest:174: error: 'class TFTLCD' has no member named 'width'
graphicstest:175: error: 'class TFTLCD' has no member named 'height'
graphicstest:177: error: 'class TFTLCD' has no member named 'height'
graphicstest:178: error: 'class TFTLCD' has no member named 'width'
graphicstest:182: error: 'class TFTLCD' has no member named 'width'
graphicstest:183: error: 'class TFTLCD' has no member named 'width'
graphicstest:183: error: 'class TFTLCD' has no member named 'height'
graphicstest:185: error: 'class TFTLCD' has no member named 'height'
graphicstest:186: error: 'class TFTLCD' has no member named 'width'
graphicstest:190: error: 'class TFTLCD' has no member named 'width'
graphicstest:191: error: 'class TFTLCD' has no member named 'height'
graphicstest:193: error: 'class TFTLCD' has no member named 'height'
graphicstest:194: error: 'class TFTLCD' has no member named 'height'
graphicstest:194: error: 'class TFTLCD' has no member named 'width'
graphicstest:198: error: 'class TFTLCD' has no member named 'width'
graphicstest:199: error: 'class TFTLCD' has no member named 'width'
graphicstest:199: error: 'class TFTLCD' has no member named 'height'
graphicstest:201: error: 'class TFTLCD' has no member named 'height'
graphicstest:202: error: 'class TFTLCD' has no member named 'width'
graphicstest:202: error: 'class TFTLCD' has no member named 'height'
graphicstest.pde: In function 'void testBars()':
graphicstest:209: error: 'class TFTLCD' has no member named 'height'
graphicstest:211: error: 'class TFTLCD' has no member named 'width'

First, you should update the IDE, to 1.5 (I have 1.54). There are considerable differences in the include files.

Hi I just downloaded 1.5.5 beta and I'm still getting the same errors

graphicstest.pde

Clue?

AWOL: graphicstest.pde

Clue?

graphicstest.pde is the sketch example file name all the files are in the zip file under TFTLCD/examples

No, the clue is that it isn't a ".ino"

AWOL: No, the clue is that it isn't a ".ino"

I don't think that's the problem here, the code still opens, after all its just plain text, I have just saved it as .ino anyway and it is still the same.

It is just text, but the .pde indicates it is maybe a library that hasn't been updated for the current version of the IDE. I can't see it because I'm posting from a very small tablet

AWOL: It is just text, but the .pde indicates it is maybe a library that hasn't been updated for the current version of the IDE. I can't see it because I'm posting from a very small tablet

.pde means Processing Source Code I have just tried it in Processing and it fails still :[

ashley: all the files are in the zip file under TFTLCD/examples

No, they are in a RAR file on your SkyDrive. The error messages make it look like you're missing a "#include" somewhere. Do you have "Arduino.h" at the top of your file?

Hi, I managed to get it working I emailed the seller, and they fixed the errors for me, and now it works :]

ashley: Hi, I managed to get it working I emailed the seller, and they fixed the errors for me, and now it works :]

That is great, I'm glad you got it working! Please say what they did to fix the errors. It really helps others who may be facing the same situation. Thanks in advance!

(If you don't know, just post the code after they fixed it.)

I bought the same shield, no problems with compiling , but there is a bright white screen without any visible activity.

My guess is, that there is a contrast voltage missing. Am I right, and what to do ?

Thanks a lot Jara