TFT_320QVT_9341 only white screen

I tried to get this display working with the UTFT lib but I only get a white screen.

The print on the rear of the display PCB reads "TFT_320QVT_9341"

|500x375 I have other displays working with UTFT so I know more or less how to use UTFT.

Any help would be appreciated.

bought it here http://www.ebay.com/itm/231418443359

Hey. Try it , type in the identification of the display screen " ILI9327 " Please tell if something moved . I have the same display and I ran it a week.

Thanks for the suggestion, this works partially, the image is too much to the left

Well. That’s what I had :slight_smile: now please copy to my file folder . Of course, make a backup copy of your file.

UTFT.cpp (27.5 KB)

It works !!

Thank you very much. Can you explain what you changed to the UTFT.cpp?

I spent over a week from morning to evening on it. I will try to write in the evening, when I'm at home. The file had in the cloud. Also, I was happy when I saw how it works. :)

Thanks for you help. i lost a day on this display without results, now you got it working.

I'm trying to build this project.

http://howtomechatronics.com/projects/arduino-game-project-replica-of-flappy-bird-for-arduino-on-a-tft-touch-screen/

The image now appears on the screen but the touchscreen is not reacting. Do you use the touchscreen ?

That's how it works. This is my setup myTouch(6,5,4,3,2); . Top calibrate the screen example Utouch .

// UTouch_Calibration // Copyright (C)2015 Rinky-Dink Electronics, Henning Karlsen. All right reserved // web: http://www.RinkyDinkElectronics.com/ // // This program can be used to calibrate the touchscreen // of the display modules. // This program requires the UTFT library and a touch // screen module that is compatible with UTFT. // // It is assumed that the display module is connected to an // appropriate shield or that you know how to change the pin // numbers in the setup. // // Instructions will be given on the display. //

And the most important. After downloading the program for me I have to reboot the system by disconnecting the USB cable. During calibration, follow the instructions on the screen.

Ok touchscreen now also works. Especially removing the USB cable was a good tip, I would never have tried that. Everything works fine now, you made my day

This is my first time trying a TFT display. I have the same problem as luxxtek above. If I use ILI9327, everything is shifted to the left. I also replaced the source file with what turla2 posted. I must be missing something, as the display is still shifted to the left using ILI9327. What control chip should I be using with turla2 source code? I’m a bit lost on this one -

Thanks -

luxxtek: It works !!

Thank you very much. Can you explain what you changed to the UTFT.cpp?

I got my display to work based on what you did. However, I can't seem to fix my screen being shifted to the left. I downloaded the .cpp file. I put it in the folder at C:/Arduino/libraries/UTFT. I replaced the existing file with it. I saved the sketch and shut down the program. I restarted it and reuploaded the sketch, but it is still shifted. Was the file supposed to go somewhere else?

Try this UTFT modified: http://www.mediafire.com/download/8tyi1ca72x1dmbn/UTFT.rar

constructor:

UTFT myGLCD(33,38,39,40,41);  // TFT ILI9341_16b

or

UTFT myGLCD(ILI9341_16,38,39,40,41);  // TFT ILI9341_16b

|500x326

Hello TFTLCDCyg,

I got the same problem than the other peoples. I have downloaded your modified UTFT and used your constructor and now, it works fine.

Thank you very much

Sincerely.

Pierre

Hola

Muchas, muchas gracias, teniendo este tipo de ayudas todo es mas facil y mas cuando se trata de pequeños "trucos" como el de desconectar y conectar para que funcione el programa de calibracion.

Saludos desde Colombia!!!

turla2:
Well. That’s what I had :slight_smile: now please copy to my file folder . Of course, make a backup copy of your file.

Hi turla2,
I try some thing that you instruct but the screen to the left, my FTF same as #luxxtek
The touch is ok. please help me.

webcam_image.jpg

Reednoel4u:
Hi turla2,
I try some thing that you instruct but the screen to the left, my FTF same as #luxxtek
The touch is ok. please help me.

Sorry, I take picture by webcam so it is a mirro.

turla2 thanks for your shared file UTFT.cpp, It works.

I wrong way to copy to the path, it have the path in : C:\Program Files (x86)\Arduino\libraries\TFT\UTFT and C:\Users\ReedNoel\Documents\Arduino\libraries\UTFT

Hi! I'm try to calibrate my TouchScreen & Mega:

turla2: That's how it works. This is my setup myTouch(6,5,4,3,2); . Top calibrate the screen example Utouch . ....

And the most important. After downloading the program for me I have to reboot the system by disconnecting the USB cable. During calibration, follow the instructions on the screen.

and I'm got error: ... cc1plus.exe: out of memory allocating 1677721600 bytes

exit status 1 Error of compilation for board Arduino/Genuino Mega or Mega 2560. ...

Can anybody to help me? Thanks!

Hi! I'm have same error too..

First off. Please verify that you actually have the display in message #1.

Then describe / post a photo of your Adapter shield and wiring.

These displays are fairly common. There are several makes of adapter Shields.

I do not have one. I bet that several members might have the same hardware as you.

David.