The Arduino instructions for creating a library are not working for me. Help!!

I have the Ultimate 2.0 robot kit from MakeBlock. Its mainboard uses the ATMEGA2560-16AU chip.

“Programming for all experience levels, Block-based programming software enables you to program your Ultimate 2.0 by simply dragging and dropping function blocks. Also supported are the Arduino IDE, NodeJS, and Python programming languages. This gives you a smooth learning curve on your way from beginner to expert coder.”

I a trying to build my first library - following the instructions for Morse at Arduino. All of the code is in place. However, my program can not find the library. It is in c/Documents/Arduino/Libraries.

The Arduino page states . . .

If the library doesn’t seem to build, make sure that the files really end in .cpp and .h (with no extra .pde or .txt extension, for example).

I have checked and all seems fine in my case. However, posting has changed the file extensions.

Can anyone help??

Morse.cpp.ino (459 Bytes)

Morse.h.ino (303 Bytes)

MorseMAM.ino (357 Bytes)

Morse_Runtine_call.ino (288 Bytes)

(deleted)

Your files have an extra ".ino" extension as your quote says they shuld not have (Morse.cpp.ino, Morse.h.ino).

However, posting has changed the file extensions.

That is nonsense. The forum software does NOT rename files or add extensions.

I'm going to guess that you drank the Window Koolaid, and failed to tell Windows that hiding file extensions sucks big time. Turn that stupid option off, and rename the files properly when you can see the extensions.

Which editor are you using to create the files ?

(deleted)

The files are listed as

Morse.cpp (Arduino file) and
Morse.h (Arduino file)

CLplaneguy:
The files are listed as

Morse.cpp (Arduino file) and
Morse.h (Arduino file)

That tells me that you have extensions turned off. TURN THEM BACK ON! Idiots at Microsoft be damned.

The library files are in

PAST "C:\Users\CL_Plane_Guy\Documents\Arduino\libraries"

Where is the setting to turn extensions on?
Is that Windows extensions of Google extensions?

Where is the setting to turn extensions on?

Did you ask Mr. Google?

The library files are actually in

I WILL PASTE THE LOCATION HERE

"C:\Users\CL_Plane_Guy\Documents\Arduino\libraries"

CLplaneguy:
Where is the setting to turn extensions on?

  • Start Windows Explorer.
  • File > Options
  • Click on the "View" tab.
  • Uncheck "Hide extensions for known file types".
  • Click "OK".

CLplaneguy:
The library files are actually in

I WILL PASTE THE LOCATION HERE

"C:\Users\CL_Plane_Guy\Documents\Arduino\libraries"

Forget about that for now. Fix the Windows file extensions setting. Then fix the extensions of the library files. That will likely solve the problem. If you still have a problem after that then we can worry about whether the files are in the right place.

(deleted)

I have Windows 7 Home Premium - Service Pack 1

I went to . . .

  1. Windows Explorer
  2. Tools > Folder options . . . > View and
  3. Unchecked "Hide extensions for Known file types > Apply > "OK"

Now my files are

Morse.cpp.ino and
Morse.h.ino

Great! Now you need to remove the .ino extensions from the files:

  • Right click on Morse.cpp.ino.
  • Click "Rename"
  • Delete the .ino from the end of the filename
  • Press "Enter".
  • Repeat the process with Morse.h.ino.

Now my files are

Morse.cpp.ino and
Morse.h.ino

Which you KNOW is wrong. So why are you not renaming the files?

pert:
Great! Now you need to remove the .ino extensions from the files:

  • Right click on Morse.cpp.ino.
  • Click "Rename"
  • Delete the .ino from the end of the filename
  • Press "Enter".
  • Repeat the process with Morse.h.ino.

Geez. Can't we expect people to know how to do stupidly simple sh*t?

Yes. You are correct and my folder set up is correct. "Morse" is a folder and NOT a file.