The IDE and the font.


In another post I was complaining about how lower case L and the number ONE look the same.
Usually capitol I has the same problem.

I was shown how to change the font and I did.

While doing this I thought to myself: "Make a backup" but as my mind set was in Arduino mode, there is no way of making commented lines.

So I couldn't/didn't.

I changed for font and it sort of worked.
There is a subtle difference between l and 1 which may be enough, but the rest of the formatting is now kaput.
a line of /'s becomes a bit fuzzy, and "ASCII art"/logos/headers what ever, become corrupt.

I changed two lines with the word FONT in them. One near the top and one a bit further down.
I was looking for editorfont and changed the first one I saw.

I like the "Times new roman" font, and tried that.

It works, but as said other problems happen and so I may have to put up with the horrible original font.
But what is/was it?



"Monospaced" is the default, I believe. You should be able to just delete that line from the preferences and have it default to the default, so to speak. I think.

You really want a Fixed-Width font for coding (like Courier, and NOT like Times.) There have been some articles about this, for example: Dan Benjamin

I believe that there are also complaints about the way the IDE renders fonts; not doing smoothing, or somesuch. I tried some of the fonts mentioned in the article above on my mac, and they didn't look very good.

you can change font smoothing options in preferences.txt


I bundled this beautiful and modern MS Segoe UI Monospaced,118440.0.html

You have to use the full name of of the font. If it's called Times New Roman, then that is what you need to put in the editor.font entry.

You might consider using this font:
It's free/open source, monospace and has good disambiguation of 0/o/O and 1/l/I -- well suited to coding.

I use DejaVu Sans Mono, it's pretty nice with a dot in the centre of the 0 so it's real easy to tell from a O.


Well I tried to change font in this file but it does not work.
I use this version: Arduino 1.5.6-r2 BETA (with support for Arduino Yún and Arduino Due boards).
Any suggestions why it does not work?

Go to preferences.txt, close the Arduino software. And make these changes:


@ RageSmirk: :slight_smile: :slight_smile: :), very clear, good advice !


I made the change to the preferences.txt file located in the programfiles/arduino/lib folder.
It made no difference. Is there something I am missing?

I'm on win 7 64 bit usein IDE v1.0.6

I made the change to the preferences.txt file located in the programfiles/arduino/lib folder.

In my copy of 1.0.6, the preferences.txt is under my user account:


I got the path by doing File - Preferences, then it shows up at the bottom of that screen. Might be worth checking on your system, in case there are two copies of the preference file.

Adobe Source Code Pro, open source font by Adobe, really good at least to me.

I prefer using this font thinner though.

This is slightly unrelated, and maybe deserves another thread, however I have a problem with the fonts that are in the IDE status lines just above and below the program script. (Attachment Screenshot-FontsProb.png)

The font has disappeared and been replaced by rectangles (ie what is usually used when a font can't render a character, or maybe in this case the font is inaccessible?).

As you can see the program font looks OK, quite good in fact. I am using an Linux variant Xubuntu 14.04, and using as an IDE font:
and with anti-aliased "on". Very easy on the eyes after a long session.

Any idea where these rectangles might be coming from?? And how I might fix them.

Another, less annoying, problem is the font used in the IDE menus have alternatives listed in black, but the selected option is listed in white against light grey. Any chance of altering that as well? (Attachment Menus.png) The AVRISP mkII programmer option is in white next to the bullet.

Cheers, Rob