The IOUSBFamily is having trouble enumerating a USB device on OS X 10.10

Hello, I'm new to arduino and I'd really appreciate any help

I got my Arduino Uno R3 to work a total of two times (successful upload of sketch) using my macbook Air, but every other time, it simply doesn't show up under serial ports.

running: sudo dmesg

d[394]: over-released legacy external boost assertions (1 total, 1 external, 0 legacy-external) BUG in process suhelperd[394]: over-released legacy external boost assertions (1 total, 1 external, 0 legacy-external) BUG in process suhelperd[394]: over-released legacy external boost assertions (1 total, 1 external, 0 legacy-external) BUG in process suhelperd[394]: over-released legacy external boost assertions (1 total, 1 external, 0 legacy-external) BUG in process suhelperd[394]: over-released legacy external boost assertions (1 total, 1 external, 0 legacy-external) BUG in process suhelperd[394]: over-released legacy external boost assertions (1 total, 1 external, 0 legacy-external) BUG in process suhelperd[394]: over-released legacy external boost assertions (1 total, 1 external, 0 legacy-external) BUG in process suhelperd[394]: over-released legacy external boost assertions (1 total, 1 external, 0 legacy-external) BUG in process suhelperd[394]: over-released legacy external boost assertions (1 total, 1 external, 0 legacy-external) BUG in process suhelperd[394]: over-released legacy external boost assertions (1 total, 1 external, 0 legacy-external) BUG in process suhelperd[394]: over-released legacy external boost assertions (1 total, 1 external, 0 legacy-external) BUG in process suhelperd[394]: over-released legacy external boost assertions (1 total, 1 external, 0 legacy-external) BUG in process suhelperd[394]: over-released legacy external boost assertions (1 total, 1 external, 0 legacy-external) BUG in process suhelperd[394]: over-released legacy external boost assertions (1 total, 1 external, 0 legacy-external) BUG in process suhelperd[394]: over-released legacy external boost assertions (1 total, 1 external, 0 legacy-external) BUG in process suhelperd[394]: over-released legacy external boost assertions (1 total, 1 external, 0 legacy-external) BUG in process suhelperd[394]: over-released legacy external boost assertions (1 total, 1 external, 0 legacy-external) BUG in process suhelperd[394]: over-released legacy external boost assertions (1 total, 1 external, 0 legacy-external) BUG in process suhelperd[394]: over-released legacy external boost assertions (1 total, 1 external, 0 legacy-external) BUG in process suhelperd[394]: over-released legacy external boost assertions (1 total, 1 external, 0 legacy-external) BUG in process suhelperd[394]: over-released legacy external boost assertions (1 total, 1 external, 0 legacy-external) BUG in process suhelperd[394]: over-released legacy external boost assertions (1 total, 1 external, 0 legacy-external) BUG in process suhelperd[394]: over-released legacy external boost assertions (1 total, 1 external, 0 legacy-external) BUG in process suhelperd[394]: over-released legacy external boost assertions (1 total, 1 external, 0 legacy-external) BUG in process suhelperd[394]: over-released legacy external boost assertions (0 total, 0 external, 0 legacy-external) Sandbox: bird(199) deny file-issue-extension /Users/prashanthcr/Library/Caches/com.apple.bird Sandbox: bird(199) deny file-issue-extension /Users/prashanthcr/Library/Caches/com.apple.bird en0: 802.11d country code set to 'HK'. en0: Supported channels 1 2 3 4 5 6 7 8 9 10 11 12 13 36 40 44 48 52 56 60 64 100 104 108 112 116 120 124 128 132 136 140 144 149 153 157 161 165 USBF: 38.487 The IOUSBFamily is having trouble enumerating a USB device that has been plugged in. It will keep retrying. (Port 1 of Hub at 0x14000000) USBF: 38.788 The IOUSBFamily was not able to enumerate a device. USBF: 39.374 The IOUSBFamily is having trouble enumerating a USB device that has been plugged in. It will keep retrying. (Port 1 of Hub at 0x14000000) USBF: 39.675 The IOUSBFamily was not able to enumerate a device. USBF: 40.262 The IOUSBFamily is having trouble enumerating a USB device that has been plugged in. It will keep retrying. (Port 1 of Hub at 0x14000000) USBF: 40.564 The IOUSBFamily was not able to enumerate a device. USBF: 41.153 The IOUSBFamily is having trouble enumerating a USB device that has been plugged in. It will keep retrying. (Port 1 of Hub at 0x14000000) USBF: 41.675 The IOUSBFamily was not able to enumerate a device. USBF: 42.564 The IOUSBFamily is having trouble enumerating a USB device that has been plugged in. It will keep retrying. (Port 1 of Hub at 0x14000000) USBF: 42.865 The IOUSBFamily was not able to enumerate a device. USBF: 43.448 The IOUSBFamily is having trouble enumerating a USB device that has been plugged in. It will keep retrying. (Port 1 of Hub at 0x14000000) USBF: 43.748 The IOUSBFamily was not able to enumerate a device. USBF: 44.333 The IOUSBFamily is having trouble enumerating a USB device that has been plugged in. It will keep retrying. (Port 1 of Hub at 0x14000000) USBF: 44.634 The IOUSBFamily was not able to enumerate a device. USBF: 45.218 The IOUSBFamily is having trouble enumerating a USB device that has been plugged in. It will keep retrying. (Port 1 of Hub at 0x14000000) USBF: 46.139 The IOUSBFamily was not able to enumerate a device. USBF: 46.992 The IOUSBFamily is having trouble enumerating a USB device that has been plugged in. It will keep retrying. (Port 1 of Hub at 0x14000000) USBF: 47.293 The IOUSBFamily was not able to enumerate a device. USBF: 47.850 The IOUSBFamily is having trouble enumerating a USB device that has been plugged in. It will keep retrying. (Port 1 of Hub at 0x14000000) USBF: 47.850 The IOUSBFamily gave up enumerating a USB device after 10 retries. (Port 1 of Hub at 0x14000000) USBF: 47.850 The IOUSBFamily was not able to enumerate a device. Sandbox: JavaApplicationS(448) System Policy: deny file-write-unlink /Users/prashanthcr/Library/Saved Application State/cc.arduino.Arduino.savedState/restorecount.plist

Your help would be really appreciated. Thank you!

Press and hold the reset button on the Arduino, then hit the upload button in the Arduino software.
Only release the reset button after you see the message “Uploading…”

Works for me … !

Do you use the latest FTDI drivers ???FTDIUSBSerialDriver_v2_2_18

I’ve installed the latest FTDI drivers, didn’t help

I’ll try the reset-upload tip.

Thank you!

The Uno R3 doesn't use the FTDI chip. It uses an Amtel chip. FTDI drivers don't affect the use of the R3.

"The '16U2 firmware uses the standard USB COM drivers, and no external driver is needed. However, on Windows, a .inf file is required."

http://arduino.cc/en/Main/ArduinoBoardUno