The Linux part is totally unresponsive and leonardo part is alive and kicking

I will make two assumption before I ask for help.

  1. Linux now is a seasoned OS, and yes you can do ANY thing with it
  2. Yun has some flows and short comings.... like lack of JTAG.

My post is asking for help to get to the boot process UBOOT; once there I will be able to reflash new image. By there I mean getting the ar7240 prompt.

My frustration is; I cannot communicate with the Linux part (Corrupted bootloader).

The Yun status now is: USB light is ON permanently!!!!!. No WiFi and No wlan RX and TX works the the Red Led function when I upload a sketch. As I said the Leonardo part is working.

Resetting for BOTH the wi-fi and the linux part NOT responding 5s, 30s, 10 min !!!!!!!!

Arduino reset is of course working.

So, is it possible to make linux do the UBoot so I can interrupt it and get the ar7240

First off, I'm not a Linux expert, so I can't really help you with uboot, but hopefully I can help get you to the prompt.

arishy:
Resetting for BOTH the wi-fi and the linux part NOT responding 5s, 30s, 10 min !!!!!!!!

The long and short presses of the reset button are to get you out of trouble if you misconfigured the WiFi settings, or mangled up some configuration files to the point where you want to start over. If Linux is not booting normally, that reset button isn't going to help you.

The Catch-22 with the reset button is that it isn't active until Linux has fully booted up. Once booted, it starts looking at the reset button, times how long it's been held down, and then runs one of two different scripts depending on the time. But if Linux isn't fully booting, it's not running the button detection code, and that button doesn't help you.

That reset button is NOT like the factory reset button on a many devices where you press and hold it while powering on, or shortly after power on. It won't fix a board that does not boot properly.

So, is it possible to make linux do the UBoot so I can interrupt it and get the ar7240

It should be possible, unless Linux is totally dead and unresponsive. The key is that you need to get to the console prompt, and to do that you need to go through a sketch:

  • Make sure no shield or external circuitry is connected to shield I/O pins 0 and 1
  • Connect your Yun to your computer using a USB cable (you can't do this over the network, because the network is controlled by the Linux side.)
  • Select your Yun's USB port in the Arduino IDE's Port menu
  • Load the YunSerialTerminal example sketch onto your Yun
  • Open the SerialMonitor
  • Give a short press of the YUN RST button
  • You should see the initial Linux boot sequence go by, including instructions on what to type to get the uboot prompt (which varies according to the Linux version you are running.)

You won't have much time to enter that response that breaks you out of the boot process and enters the uboot command line. You will likely have to do this once to see what you need to type, then type that in the send string box of the SerialMonitor. Then, hit YUN RST again, and quickly hit the SerialMonitor's Send button when the prompt appears. Once you are in the uboot prompt, the special timing concerns end.

Once I got your response, I checked your forum responses to cases very similar to mine.

And you stated clearly if the blue USB led is permanently ON, it is an indication of bricked YUN and replacement is the solution.

Well; I have Blue usb LED ON whenever I power the YUN.

As per your instruction, I did it step by step and to make sure that the Serial terminal is communicating I did two things I type f and clicked send, RX flashed. Also I send ~0 and the terminal responded back with speed set for 57000. Then I pressed the Yun reset ( it is actually called the AR9331 Reset )

Nothing ...and no RX lights flashing indication that Linux side is sending ANYTHING.

What I am hoping for is a way to reflash the 16M with the UBoot...but I do not know how to talk to dead linux

arishy:
Then I pressed the Yun reset ( it is actually called the AR9331 Reset )

You must have a different version of the Yun than I do. But I would think the general concepts and procedures should be the same. But, just to be sure, you are talking about the single board Yun that has the AR9331 and '32U4 processors on it, and not the Yun Shield that only has the AR9331 and connects to another board. If you have the shield, then the details of the procedure will be different, and I have no experience with the shield.

If you are getting nothing at all out of Linux, then it sounds like it is truly dead.

You mention a blue USB LED: on my board, that LED is white. On power up, it is completely dark, and it comes on brightly once Linux is fully booted up (takes about a minute.) I've heard from others that if the white USB LED comes on dimly right away, that it is a non-recoverable problem with the Linux side of the Yun.

My Yun is the Genuine Yun made by Arduino and not a shield. It has both the leonado chip and the Linux AR9331.

So, it is not a total loss since I can still use the Leonardo part.

I hope this is the same as yours.

I do not know how much time you spent with your Yun, but for me the more problems I get with HW/SW the more I get knowledgeable with whatever I do.

I have quite a few RP's and my Linux road can be filled quite a lot using the PI.

I will keep reading about flashing the Uboot, even if I have to do some soldering. I believe there are ways to do it and a challenge for me to pursue. I have time in my hand.

P.S. The usb led is blue and you are right it blinks rapidly when dealing with the Linux part
The wifi led is white when I have WiFi on

It sounds like we have some significant differences between our boards, at least where it comes to LEDs. I have four of them, which I bought three years ago, shortly after they came out. I guess they've made some updates.

Good luck with your efforts to revive the Linux portion!

Have you tried the methods mentioned here (Ok I know you have tried at least one of them)

When I bricked mine I used the TFTP method and then when I upgraded I used the SSH method.

Unfortunately, the first two of those three methods require that the Linux side is booted up normally - that isn't happening in this case, so those two methods are not available to arishy.

The third option requires that the Linux side is booting up to the point that the uboot prompt is available. Again, it appears that that's not happening in this case.

With the Linux side being totally unresponsive, the standard ways of reflashing the system don't work. Fixing this unit is likely going to start involve some serious hacking: trying to cobble some sort of hardware debugger interface, unsoldering/replacing the flash memory chip, etc.

If you solve this please post how because I'm dealing with the exact same issue and it's incredibly irritating.