Thermal printer prints Unreadable characters

Hi
Am working on thermal printer (model: CSN-A2-T) on linux environment.
I configured the serial port and when i try to initailize the thermal printer using the below commands from linux bash environment:
stty -F /dev/ttyO4 19200 → to set baud rate
echo -e “\x1B” > /dev/ttyO4
echo -e “\x40” > /dev/ttyO4 → Initialize (ESC @)
echo -e “\x1B” > /dev/ttyO4
echo -e “\x37” > /dev/ttyO4 → print setting
echo -e “\x50” > /dev/ttyO4 → heating dots
echo -e “\xFF” > /dev/ttyO4 → heating interval (ESC 7 80 255)
echo -e “\x18” > /dev/ttyO4
echo -e “\x35” > /dev/ttyO4 → print density
echo -e “\x0A” > /dev/ttyO4 → Line feed (LF)

Unreadable characters (characters are from code table PC437) are been printed.
I tried to change the character set as below:

echo -e “\x1B” > /dev/ttyO4
echo -e “\x52” > /dev/ttyO4
echo -e “\x30” > /dev/ttyO4 → character set to 0:USA (ESC R 0)
echo -e “\x0A” > /dev/ttyO4

But still unreadable characters are printer.
Please let me know how i can configure thermal printer from linux bash environment.

How are you connecting the printer to your serial port? Is it a regular RS232 port (with a 9-pin or possibly larger connector)? A quick Google search reveals that the CSN-A2-T works with TTL serial signals, while the CSN-A2-R works with RS232 serial signals.

The printer is connected via TTL serial signals and connected with 5v power supply.

Finally the problem solved.
The problem is due the RS232 to TTL converter been used between the Thermal printer and the development board. This resulted in dual conversion of the uart signals.
After removing the converter circuit the character on the printer are readable.
Thanks for the support.