time on serial outputs

hi,
since two days, every time when I am printing with Serial.print() the actual time is printed at first and then the printout I want to print, eg.
Code for a Nano:

void setup() {
    Serial.begin(19200);
    while ( !Serial ) ;
...
}

loop()
...
v16=82;
v8=1;
lowbatt=0;
mspeed=76;

sprintf(outstr,"W%03dR%02dB%dM%03d",v16,v8,lowbatt, mspeed);
              Serial.println(outstr);

The expected result:
W082R01B0M076

the real result:
20:20:45.786 -> W082R01B0M076

Some days ago I played with a Teensy3.2, and varied the "Optimize" settings. I am not sure but I believe, after setting Optimize to debug, printig of the acutal time began.

Now back on the Nano which is using a different COM setting (COM 8 on Nano, COM 19 on Teensy) I always get the time at first on the printout, once every printed line.
The time comes from the PC (Win7) because the Nano and nothing in the environment has a rtc.

How can I switch off printing the time?

(deleted)

How can I switch off printing the time?

If you mean in the serial monitor on the Arduino IDE look at the bottom of the window on the left, there is a check box 'show timestamp', un-check it.

(deleted)

spycatcher2k:
It can’t be that! The OP would of tried that already before logging in to the site and typing up a question!

We shall see! Have you never made a mistake that you can’t find, only to find it and realise it was something really easy, which you should have seen straight away? I certainly have :o

hi,
it is so simple: you are right, there is a button "show time stamp". I never noticed it, and therefore was searching in the code and the configuration.

Thank you

It can’t be that!

It is so simple: you are right, there is a button “show time stamp”.

Ah… :slight_smile:

(deleted)