Timeout beim Hochladen

Hallo,

nun habe ich folgendes Problem: Das Hochladen meines Sketches funktioniert nicht mehr. Es erscheint immer folgende Fehlermeldung:

Arduino: 1.8.0 (Windows 10), Board: “Arduino/Genuino Mega or Mega 2560, ATmega2560 (Mega 2560)”

Der Sketch verwendet 3850 Bytes (1%) des Programmspeicherplatzes. Das Maximum sind 253952 Bytes.
Globale Variablen verwenden 360 Bytes (4%) des dynamischen Speichers, 7832 Bytes für lokale Variablen verbleiben. Das Maximum sind 8192 Bytes.
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_getsync(): timeout communicating with programmer
Beim Hochladen des Sketches ist ein Fehler aufgetreten

Dieser Bericht wäre detaillierter, wenn die Option
“Ausführliche Ausgabe während der Kompilierung”
in Datei → Voreinstellungen aktiviert wäre.

Eingefügt habe ich seitdem nur den Code zur seriellen Datenübertragung.

Gruß
Paul

Techniker89: Eingefügt habe ich seitdem nur den Code zur seriellen Datenübertragung.

Seit wann? Habe ich etwas verpasst? Und kannst Du den Code zeigen oder ist der geheim?

Gruß

Gregor

In der IDE gibt es bei den Voreinstellungen die Möglichkeit, die "Ausführliche Ausgabe während Hochladen" anzukreuzen. Liefert möglicherweise den erhellenden Hinweis.

Dann nimm probehalber den Blink-Sketch, um irgendwas in Deinem Sketch auszuschließen.

Hallo,

es müsste daran liegen, dass ich während des Uploads GND beider Arduinos verbunden habe. Ohne funktioniert es.

Techniker89: es müsste daran liegen, dass ich während des Uploads GND beider Arduinos verbunden habe. Ohne funktioniert es.

Dann hast Du möglicherweise eine "Brummschleife" oder unterschiedliche Massepotentiale mit Ausgleichsströmen.