Timeout YunClient

Ciao. ho un problema che credo (non ne sono certo) sia dovuto ad un timeout. Facendo delle prove sono arrivato a sintetizzare qualche riga di loop (qui riportato) in modo da andare bene ad analizzare il problema.

void loop() 
{
  // Lo scketch si mette in attesa di messaggi entranti attivando un client verso Yunserver
  client = server.accept();
  // Nuovo messaggio in arrivo?
  if (client) 
  {

    delay(5000);
   client.println("prova");
    Console.print(client.readString());

    // Alla fine chiude il client
    client.stop();

  }

}

Se il delay è inferiore a 5000ms sul browser viene restituito il messaggio "prova". se >= non restituisce più nulla.

Premetto che anche sostituendo il delay con millis() non cambia nulla.

Ho trovato un' articolo che parlava del mio stesso problema, ma non sono riuscito ad implementarlo. Allego il link.https://github.com/arduino/YunBridge/issues/23

Qualcuno ha avuto il medesimo problema?

Grazie

stefano_8805: Ho trovato un' articolo che parlava del mio stesso problema, ma non sono riuscito ad implementarlo. Allego il link.https://github.com/arduino/YunBridge/issues/23

Perché non sei riuscito ? Che difficoltà hai incontrato nell'editare il file /etc/config/arduino e cambiare il valore di timeout?

Guglielmo

ho usato winscp per navigare i file di arduino, ma quando ho aperto il file "arduino", non ho trovato alcuna riga "timeout_socket"

Il contenuto di /etc/config/arduino dovrebbe essere più o meno questo:

config arduino
option password ‘775e9f944188a7bcb36e9ca5dc51672b44bcceeb7d56d89dfb914eb3a1ff2d69’
option secure_rest_api ‘true’
option socket_timeout ‘5’
option access_point_wifi_name ‘Arduino’
option wifi_reset_step ‘clear’

config wifi-device ‘radio0’
option channel ‘auto’
option country ’00’

config wifi-iface
option mode ‘sta’
option ssid ‘myssid’
option encryption ‘psk2’
option key ‘passwd’

config interface ‘lan’
option ifname ‘eth1’
option ipaddr ‘192.168.1.21’
option netmask ‘255.255.255.0’
option proto ‘static’
option metric ’10’

... e la riga coinvolta dovrebbe essere quella che specifica " option socket_timeout '5' "

Guglielmo

Io ho questo

config arduino option password '775e9f944188a7bcb36e9ca5dc51672b44bcceeb7d56d89dfb914eb3a1ff2d69' option secure_rest_api 'false' option wifi_reset_step 'clear'

config wifi-device 'radio0' option channel 'auto' option country 'IT'

config wifi-iface option mode 'sta' option ssid 'WIFI1' option encryption 'psk2' option key '01234567'

config interface 'lan' option proto 'dhcp'

Prova ad aggiungere la riga ...

option socket_timeout '15'

... e vedi se funziona ;)

Guglielmo

Già fatto, ma niente da fare.

... mmm ... ma è una vecchia Yún fatta da Arduino.cc (detentore di questo forum) o è una di quelle nuove fatta da Arduino.org ?

Perché la nuova (quella di Arduino.org) è stata parzialmente ridisegnata anche nel SW e quindi, se si tratta di quest'ultima ... bisogna che chiedi nel loro forum.

Guglielmo

infatti è una YUN nuova quindi ho scritto sul forum Arduino.org. Ad ora non ho visto risposta. Speriamo rispondano a breve.

stefano_8805: Speriamo rispondano a breve.

... considera che, [u]se ben ricordo[/u], li TUTTI i post sono soggetti ad approvazione del moderatore, quindi ... prima deve essere approvato per essere visibile a tutti, poi, forse, qualcuno risponde ::)

Guglielmo

Buongiorno. il post è stato letto ma per ora non ho alcuna risposta. Ho fatto qualche altra ricerca e trovato qualche articolo interessante, ma ha bisogno di un aiuto.

in particolare qui http://forum.arduino.cc/index.php?topic=268081.0 dicono che aggiornando alla versione 1.5 mi permette di fare ciò che cerco.

io però non so da dove verificare la mia versione.

Qualcuno mi sa indicare come posso verificare la cosa?

la cosa che mi conforta il "limite" del timeout è problema frequente.

Ti ripeto che la Yún aggiornata da Arduino.org è diversa e monta un FW diverso da quello che era per Arduino.cc quindi ... ... inutile che chiedi qui, DEVI chiedere sul loro forum (... e probabilmente usare il loro IDE cone le loro librerie).

Guglielmo