timer goes up to 10:00 minutes when starting up arduino nano

Please help! I copied the code here https://www.instructables.com/id/Kids-Kitchen-That-Says-BEEP/. When i start the arduino up, without pressing any button, the timer just keeps going up til it reach 10:00 and stays there. Thanks in advance!

IKEA_DUKTIG_i.ino (14.1 KB)

Please help with the code attached. when i start the arduino, timer continue to increase.
source: https://www.instructables.com/id/Kids-Kitchen-That-Says-BEEP/

IKEA_DUKTIG_i.ino (14.1 KB)

Haven't you already got a thread on this ?

Sorry for the double thread, my son created it last night and i did not know about it. how do i delete this one or the other?

Report yourself to a mod and explain what happened

My guess is that one of your buttons is wired incorrectly, or has a pullup/pull down missing.

Threads merged.

Thanks for the response. I’ve tried unplugging all the buttons but the problem persists.

exactly. the button without a pullup/down is exactly like a button that is unplugged

that did it. I am not sure why the pull_up isn't working on pin D13. i moved it to D2 and worked perfectly. Thank you!

Pin 13 has the built in LED on it. Could that be a factor ?

The LED is driven by an op-amp, not by an IO pin directly.

That was not always the case. On the first Unos and the R2 variant the LED was driven from a pin via a 1K resistor and we don’t know which Arduino variant the OP is using