Times you freaked, but then the problem went away.

Im sure we have all had these moments.
My most recent was when i thought my arduino’s ftdi chip had fried, but then i relised i was steping on the usb extension cord.
I was buying a replacement (the board smelt like sweet smoke, never good), when the computer beeped.
Instant relief, and embarrasment.
Anybody got any of these moments?

I too couldn’t figure out why my Arduino wasn’t responding to Serial communication, and also why my keyboard tray wouldn’t close fully (even when I shoved it hard).

Then I discovered that the USB cable had become caught in the keyboard tray’s sliding mechanism, and that my persistent shoving had severed the cable almost in two :O. It’s a miracle nothing shorted out! :stuck_out_tongue:

Well I was swapping in and out a 328 processor on my Arduino clone and once it didn’t start-up. Looking carefully I could see I plugged in the 328 backwards. Yea I kind of freaked, but just reinserted it correctly and it ran AOK. Pretty rugged those AVR chips. :wink:


I could see I plugged in the 328 backwards.

I did the same yesterday. Freaked my out, cause it was working fine before i reprogramed it in my Diemilanove

I already installed a few IC (about 3) the wrong way and freaked out on why it doesn’t work and why my battery and ICs were heating up.

Then I realise they were installed the wrong way and started freaking out AGAIN because I thought I may have damaged my whole project.

But it was fine…thank you Inner IC Pin protection!

5 minuites after that i had problems with the arduino clone rapidle reseting every(roughly) centisecond. Figured out that a standard 9volt battery doesnt need decoupling, but three 3v button cells do.
Strange. I was worrying my ossilater was shot, and i would have to wait for a replacement.

In general, it’s a good idea to decouple any power supply, but some seem to be more temperamental than others (ie, batteries).

As i soon found out. I thought that because the 9v cell worked fine, that the three 3v lithium button cell battries (btw, how many mAh can i expect out of them?) would work.
I looked at the power in my ossilscope, and saw no reason for the loosely precise centi-second resets, as a 0.01nF capacitor corrected the problem, and i so nothing on my scopes highest time setting. But then agin, my scope is old( and poorly desinged near the inputs), and i haven’t checked my probes for gained inherent capicentance recently.

The cells’ mAH ratings will depend on the part number.

Try googling the number you see on the battery.

Well, there was the time I tried to read my boss’s email, and it said “By the way Bill, why are you reading my mail?” :slight_smile:

Years ago I was working for a small charity. I thought I’d managed to break their PC because it’d restart every time something was sent to the printer.

After a good few hours of testing I discovered it was a power problem. The laserprinter firing up would leave insufficient power on the mains circuit for the PC to run, so it’d drop out. It dropping out would stop the print job so it’d boot up again.

I wrote the reconstruction DSP software for a range of industrial computed tomography machines.
The software itself is simple in concept, but involves many stages and corrections depending upon the modality of the scanner and the physical construction of the scanner itself.
One particular machine was exhibiting obvious streaks and rays on the reconstructed slices and was due to ship, and I was summoned to the customer’s premises to fix it.
After seventeen days of twelve hour shifts, I’d got the speed of reconstruction more than halved, tidied up a lot of other problems, but the streaks persisted.
No amount of tweaking and recalibrating would shift them.
I had to fly home for my brother’s wedding, and left under something of a cloud.
I got a fax a couple of days later to say that when the machine was dismantled ready for shipping, the detector array was found to have been mounted the wrong way round, and just one detector was partly shaded by the housing, and this alone was causing the streaking.

You know thoses old crt-based camreas?
I was using one and some magnets mounted on motors on the ends of servos to do some image distortion.
However i didn’t account for a magentic shadow mask, and a big rare earth magent went slaming into the active tube at an insanely fast speed.
Several thousand volts made me lose 4 servos, a few pager motors, a crt-camrea, and a tripod.
The tripod had the misfortune of being grounded, it was locked into place by the jolt.
I freaked, cause the camrea was worth about $200, and the only spare parts i had for it were some random resisters and capicators, and a new tube.
I was shocked to find out that the shock had been redirected form the camrea’s boards by the tripod.

Anybody got any of these moments?

Twice a day at least.

I was working on a production color machine.

I was troubleshooting a document feed jam problem and went to pull the sensor that the manual pointed at being the problem. When I pulled the sensor I shorted it to frame ground.

I paniced and called every supplier I could find trying to locate a power supply ($1100US) to find out that it was a protected power supply.

All I had to do was shut it off, unplug it for 5 minutes and all was wonderful other than it still jammed.

wound up being a bent sprint on the return spring for the sensor flag if I remember correctly.

Last night (Sunday) I was replacing the batteries in a large UPS I use in my server closet. Two large 12V 18AH batteries connected in series. I first connected the series fuse link using the supplied bolts and nuts, then went to hook up the connector pigtail.

I was tightening up the nuts on one side, thinking to myself “ok, gotta be careful here, one slip too far on this wrench and…” - !!! SNAP !!! - and a small but bright flash; and I dropped the wrench.

Direct (brief) short on the batteries, but the fuse didn’t blow - although a small chink got taken out of the wrench by the arc. I completed the assembly, tested the UPS, all was fine.

Moral of the story: Next time when I replace the batteries in that UPS, I’ll connect the connector pigtail first, then the fuse. No possible way to short the battery doing it that way.

My “duh” moment for the weekend, I guess.