Too early for IDE 2.0 Beta release

I use the IDE ver. 1.8.51. It works quite well.
I have been hearing about a new release of the IDE ver. 2.0 beta.
I thought I'd try it.
From what I have been discovering through my attempted use of 2.0 and what I see online from others, I believe the developers were a little too enthusiastic about getting this version to the user community.
I run Windows 10 and I've never been able to get a sketch to upload -- the only thing I was able to do is compile. I tried lots of different things to get it too work, many of which I got from the forum and various online sources.
IT's just too early!

Which version of 2.0 are you using bearing in mind that it is still in beta ?

What happens when you try to upload a sketch ?
Which Arduino are you using ?

The IDE version (or filename) is: arduino-ide_2.0.0-beta.12_Windows_64bit.exe
When I click on Upload, nothing happens -- no messages anywhere -- nothing!
When you ask, "Which Arduino are you using?", I assume you mean which board am I using! If that is correct, then the answer is "UNO".
I have noticed quite a few people are having difficulty with this IDE. I realize it's 'beta', but over the years, I've used a lot of beta software, but nothing like this.

Bob;

I replied on the forum.

Regards -- Ray

@ptillisch - one for you maybe ?

I disagree. It is never too early to publish open source code. The beta release of the Arduino IDE was done to offer the Arduino community the opportunity to participate in the development of this free open source tool that will be a cornerstone of the Arduino project for decades to come.

This has resulted in lots of invaluable feedback and contributions.

If you are only looking for a stable tool to use for development of your Arduino projects, then it is indeed too early. Use Arduino IDE 1.8.16 instead. But if you want to help us out by beta testing or submitting proposals for improvements to the code, you are very welcome.

FYI, Arduino IDE 2.0.0-beta.12 is significantly outdated at this point, so beta testing reports from that version may no longer be relevant. I recommend beta testers use the nightly build from the links at this table:

or at least the latest release, which is available for download from the "Assets" section of this page:

This is a known bug. The instructions for the workaround are here:

https://forum.arduino.cc/t/upload-does-nothing/930864/28

It is being tracked by the Arduino IDE developers here:

Thanks for your reply. I did as you suggested and it pretty much worked as you indicated. I now see my board (UNO clone) on COM 7 and I can upload sketch(s) to it. My USB to serial (VCP) uses a Silicon Labs CP210x, so it was not identified. I tried things like this: First I launched the IDE and it did not know anything about the UNO. I then lugged in the USB cable from the UNO and the IDE appeared to find it. At this point I'm going to consider this issue resolved so I can concentrate on actually using the IDE. Perhaps I'll be able to make a real contribution to the effort as I try my various boards. The one I'm particularly interested in is the ESP32 since I'm using it in a course I'm taking. Anything I encounter that looks like an issue for the development team, I'll be sure to capture as much info as I can about the issue and report it on the forum. Thanks again for your help.
Ray

I may have been too hasty in thinking victory was at hand.
I now have the exact same problem with the ESP32 DEVKIT V1 board.
There must be some well-defined procedure to go through when going to a new board -- isn't there?
I have quite a few boards that I'll want to use with the IDE 2.0.
I hope I don't have to go the entire procedure again that I did for the UNO!
What do you think?
Ray

I'm not able to get the solution to work with my DOIT ESP32 DEV KIT V1 board (i.e. NOT reliably). The Tools->Port menu shows COM5(CP210x) rather than the board name?

I apologize for that.

The first workaround I found required the use of that dummy boards platform. While I was writing the instructions, I discovered a way to accomplish the same thing without the need to install anything special. So I removed the instructions for using the dummy platform, but forgot to remove the original mention of the need to install it.

Please do this:

  1. Select Tools > Board > Boards Manager from the Arduino IDE menus.
  2. Scroll down through the list of platforms until you see "zzInoVIDPID by per1234".
  3. Hover your mouse pointer over that entry in the list. You will see a rectangle that says "INSTALLED".
  4. Hover your mouse pointer over the "INSTALLED". You will see the word change to "UNINSTALL". Click on it (it's actually an uninstall button even though it doesn't look much like one).
  5. Wait for the uninstallation to finish.

You can now follow the regular workaround instructions from Upload does nothing - #28 by ptillisch


As the author, I'm biased, but I find that dummy platform to really useful when working with boards that have chips like the CP210x because it allows me to easily identify which serial port is which on my computer.

Unfortunately, the automated board selection feature of Arduino IDE 2.x makes the platform more difficult to use (it is best suited for use with the Tools > Port menu like in the classic IDE). So maybe you will give it another look once the IDE is working better for you, but for now I think it is best to uninstall it in order to remove any unnecessary complexity from the situation.

ptillisch;
Thanks for the reply. It does seem to work now, however, the board selection menu looks like this:
image
That yellow triangle with the exclamation mark is what I typically see in the OS device manager window under "Other Devices".
It does appear to allow me to upload a sketch -- should I just ignore the Yellow Triangle?

I'm very glad to hear that!

Yes.

This :warning: icon is normal and expected when using one of the "not identifiable" boards. What it is intended to do is communicate to the user that the IDE is not certain the selected port is really the Arduino board.

The use of this icon was not really a good choice by the IDE developer because the :warning: icon gives the impression that something is wrong even though with a board such as your ESP32 it is normal and expected that the board is not identifiable. The need to improve this poor user experience is being tracked by the developers here:

One final question.

Assuming the developers of IDE 2.0 are interested in the opinion of the users regarding the overall goodness of the user interface design, who should I send my comments to on the UI design?

Regards -- Ray

This forum category is the appropriate place for support requests, general discussion, and unstructured feedback.

Well defined, formal bug reports and feature requests should be submitted as issues to the Arduino IDE 2.x code repository on GitHub:

https://github.com/arduino/arduino-ide/issues

Please do a search of the existing issues before submitting a new one to avoid duplicates.


I try to act as a bridge between the forum and GitHub by identifying reports of previously unknown bugs and transferring them to GitHub and also by linking existing formal reports back to the forum so that the affected users can easily track the progress on their resolution. However, I am somewhat limited in that because I make a policy to only report bugs I am able to personally reproduce, and some bugs only affect a subset of users. So it is good for the users to directly submit reports when possible.

Even then, I have observed that sometimes discussion that occurs here with the forum community provides refinements to reports by the time they reach the issue tracker on GitHub. So you are always welcome to share your ideas here even if you plan to also report them on GitHub.