Tools > Serial Port Is Greyed Out On Ubuntu 14.04 In Arduino

I have worked multiple hours trying to solve this issue from other forum posts, but non of them have worked. I am currently using an Arduino Uno r3 board. I have had it for a couple of years but I have NEVER been able to use it because it wouldn't display on a mac, windows or ubuntu computer. After two years, I finally caved and decided to ask for help. ANYTHING is greatly appreciated. Thank you for your time!

On Ubuntu you need to belong to the dialout group to access the ttyACM ports. In a terminal enter groups and press enter. If dialout doesn't show you need to run adduser and join. In a terminal run, sudo adduser YourUserName dialout, logout and login after you run adduser.

If that doesn't resolve the problem it must be corrupted firmware in the USB-to-serial converter chip or a hardware fault on the board. Try the board on another machine(I guess you have), try another board on your machine, try a different USB cable.