Touchscreen reads input, but I can't make anything appear (UTFT)

Howdy, and happy new year all. I’m hoping someone who has experienced this can guide me in the right direction.
I bought these two touchscreen shields, and so far I have only been able to read input from them using the touchscreen.h library - I’ve been unable to display anything to either shield. I’m running a mega2560 board.

I’ve tried using UTFT, adafruit_gfx, and the library contained via the link to the shields above. The reseller-supplied library doesn’t compile (and I am not good enough at debugging to understand why tbh, but I’m trying to learn).

Using UTFT, I have tried the following declaration for the ‘red’ shield:

#include <UTFT.h>
UTFT myGLCD(HX8347A,2,1,3,4,300); 
//I've also tried UTFT myGLCD(HX8347A,A2,A1,A3,A4,300);
void setup(){
   myGLCD.InitLCD();
   myGLCD.clrScr();
   DrawHomeScreen();
}

I don’t have anything specific to drawing the screen in the loop, since I assumed that was handled by the setup (at least initially)

The DrawHomeScreen method is as follows (simple)

void DrawHomeScreen()
{
  //Text Intro
  myGLCD.setBackColor(0, 0, 0);
  myGLCD.setColor(255, 255, 255);
  myGLCD.setFont(BigFont);
  myGLCD.print("Arduino TFT Tutorial", CENTER, 10);
  myGLCD.setColor(255, 0, 0);
  myGLCD.drawLine(0, 32, 319, 32);
  myGLCD.setColor(255, 255, 255);
  myGLCD.setFont(SmallFont);
  myGLCD.print("by ME", CENTER, 41);
  myGLCD.setFont(BigFont);
  myGLCD.print("Choose example", CENTER, 64);
}

Would really love and appreciate some feedback on where I’m screwing up.

Apparently nevermind. I was using the wrong software libraries. I needed to be using MCUFriend libraries. Once I did that, I was able to run a simple test and get it to display. We're on our way now!