Touchshield Slide - file includes problem

I’m porting an existing project / menu system to the Touchshield Slide and am having some troubles. It seems the antipasto compiler works differently from Arduino 23 / v1.0, being unable to link the file includes and I get this kind of thing:

Handling the compile 1
Saving sketches...
Sketches saved.
compile(), new thread run about to sketch.compile()
     [echo] Building TouchShield Slide libraries...
     [echo] Building TouchShield Slide board target...
     [echo] Building test for the TouchShield Slide core...
     [exec] R:\TEMP\build3415606779263194787.tmp/targets/body/build/sketch/sketch-wrapper.o: In function `__static_initialization_and_destruction_0':
     [exec] R:\TEMP\build3415606779263194787.tmp\tmp\test\/test.pde:9: undefined reference to `Menu::Menu(char*)'
     [exec] R:\TEMP\build3415606779263194787.tmp\tmp\test\/test.pde:10: undefined reference to `LCDMenu2::LCDMenu2(Menu&, unsigned char, unsigned char)'
     [exec] R:\TEMP\build3415606779263194787.tmp\tmp\test\/test.pde:12: undefined reference to `Menu::Menu(char*)'
     [exec] R:\TEMP\build3415606779263194787.tmp\tmp\test\/test.pde:13: undefined reference to `Menu::Menu(char*)'
     [exec] R:\TEMP\build3415606779263194787.tmp\tmp\test\/test.pde:14: undefined reference to `Menu::Menu(char*)'
     [exec] R:\TEMP\build3415606779263194787.tmp/targets/body/build/sketch/sketch-wrapper.o: In function `menudisplay()':
     [exec] R:\TEMP\build3415606779263194787.tmp\tmp\test\/test.pde:25: undefined reference to `LCDMenu2::display()'
     [exec] R:\TEMP\build3415606779263194787.tmp/targets/body/build/sketch/sketch-wrapper.o: In function `menuinit()':
     [exec] R:\TEMP\build3415606779263194787.tmp\tmp\test\/test.pde:18: undefined reference to `Menu::addChild(Menu&)'
     [exec] R:\TEMP\build3415606779263194787.tmp\tmp\test\/test.pde:19: undefined reference to `Menu::addChild(Menu&)'
     [exec] R:\TEMP\build3415606779263194787.tmp\tmp\test\/test.pde:20: undefined reference to `Menu::addChild(Menu&)'


BUILD FAILED
C:\Antipasto\hardware\arduino\cores\touchshield\build.xml:136: The following error occurred while executing this line:
C:\Antipasto\hardware\arduino\cores\touchshield\src\template\build.xml:154: The following error occurred while executing this line:
C:\Antipasto\hardware\arduino\cores\touchshield\config\build.ccmacros.xml:45: exec returned: 1

Total time: 1 minute 0 seconds

Project is attached. Ideas are most welcome.

test.zip (4.01 KB)

It seems the antipasto compiler works differently from Arduino 23 / v1.0

Have you asked at the Chevy dealer lately anything about the problems you are having with your Ford?

PaulS:

It seems the antipasto compiler works differently from Arduino 23 / v1.0

Have you asked at the Chevy dealer lately anything about the problems you are having with your Ford?

lololol, sory cant resiste to god sense of humor :blush:

Have you asked

Oh Paul :) I give it a 5 (of a possible 10), you are much funnier in other threads.

All kidding aside, I did send a message to support. I figured I'd get a reply quicker here.

J

update: i received a reply from Liquidware and will post a solution when found.

I am also having some issues with the new Antipasto IDE and Touchshield Slide. Liquidware support is challenging to connect with...where did you send your support request? Thanks.

dave.

I sent my support request to Mike G. He wasn’t able to help me out with this issue.