Tower Pro SG-90 + Arduino Problem?

Hi, for my project i tried using Tower Pro SG-90 9grams micro servo.

The basic servo sweep sketch did not work, when i load the sketch the servo comes back to 0 position and wouldn't move from there. Itried with four Tower Pro SG-90 servos and all show the same behavior.

However when I tried the same with Hitec Hs-65 micro servo, they work without a problem.

So the big question, Are there any compatibility issues between Tower Pro SG-90 and Arduino? or all my servos are broken? :frowning: Has anyone else faced issues with them?

Your first post can not contain links. Your 18th post could (and should) have.

In the immortal words of Captain Jean Luc Picard, "Make it so!"

Hi Paul,

I cant make out what your saying. You want me to post some links to the servo specifications?

You want me to post some links to the servo specifications?

Yes. That was the general idea.

Here is the link to the product page or Tower Pro official website. It has the details for the servo:

Sadly this page has little to point to why you would be having problems. Most servo problems are down to an inadequacy power supply capacity but this page does not give the current rating of the device. Without that it is hard to know at a distance if power is your problem. Can you do any measurements? Current taken when you try and drive it and what voltage is across the device when it is moving.
How are you trying to drive them (software wise).