"Transfer incomplete"

Hello everyone,

I am new to arduino software and I am not an expert in programming. I am trying to upload my sketches to Intel edison board using arduino intel software. Everything was working fine until 2 days ago when i saw that my sketch wasnt wokring properly but was getting uploaded. I noticed in the black screen at the bottom that it said "Transfer incomplete". It happened to every other sketches i tried to upload. Board and com port both are correct. I also tried restarting everything but it didnt work. Also after 2 days its doing the same thing.

Only thing displayed in black screen is "Transfer incomplete" , while it says "Done uploading." in the blue status bar.

Do you know what the problem might be?

Thank You in advance

Have you selected the correct board in the IDE?

Yes board and com port both were correct

Have you tried uploading a simple sketch, like Blink?
How big is your sketch?
Will it fit in the Arduino's memory?

Yes I tried uploading blink but i got the same error

I haven't got an Edison board, so I can't suggest anything further except that you include the word "Edison" in your subject title so as to attract replies from those that have some experience with that board.