Trick for DTR / RST issues with Serial adapters and boards like Mega2560

[EDIT: this actually doesn't work any better than resetting manually; only worked for me because there was no user sketch on the board initially. A 0.1uF cap between the adapter's DTR and the board's RST does work...]

I programmed my new Robodyn "Mega pro mini" today for the first time.
The board doesn't have a DTR pin, and as described in many posts if you connect your serial adapter's DTR pin to the Mega RST pin then the reset doesn't happen on the Mega (forgot the details, the DTR stays high or low instead of coming back to low/high).
The typical advice is either to remove a capacitor on the adapter, or to manually hit the reset button. Here is an alternative that worked perfectly for me for several times:
- connect the adapter's DTR to the Mega RST
- watch the Mega's blinking LED
- as soon as the blinking stops (the adapter just tried to reset the board), unplug the DTR/RST cable
... that allows the Mega to complete the reset and the programming goes fine.
Seems easier to me than trying to manually hit reset at random times.

Franck