Tried 5+ times to update Atmega8U2 on SMD Uno with no luck

Hi all,

I’m new to microcontrollers / Arduino and cannot seem to figure out what I’m doing wrong. I have an SMD Uno with serial #317856 and I think I have the bootloader problem because when I plug in the board, the last sketch loaded does not run. It’s supposed to, right?

I’ve followed the procedure documented at 5 or 6 times. I’m using Windows XP SP3 with Flip v3.4.2 and after a reset the board shows up as an AT90USB82. What is a puzzle is that when Flip updates the Atmega8U2 with Arduino-usbserial-uno.hex it does all the steps (Erase, Blank Check, Program, Verify) in < 2 seconds which seems too fast? When I tried updating with Arduino-usbserial-mega.hex it spends about 20sec on the “Program” phase then fails with “Cannot write to USB.” Back with Arduino-usbserial-uno.hex – everything works according to the procedure but after unplugging the board and plugging back in and then loading a simple sketch (“Blink”), that runs fine but after I unplug and plug back in the sketch isn’t running. So I’m lead to believe that the firmware is not fixed.

Maybe I have the wrong firmware .hex file? The md5sum I have is:
8e01ee236e70bbea43f7eb4e11c9688a Arduino-usbserial-uno.hex

Maybe I have a different problem?

Thanks for any advice you can offer. I’m stuck.

  • Jim

Can someone confirm that I have picked the correct firmware file for the Uno SMD?

Sounds like you programmed the 8U2 just fine (and yes, it's reasonable for it to program very quickly) -- but that doesn't fix the bootloader bug at all, which is a completely unrelated issue.

If your sketches run properly when you upload them, but not once you unplug and replug the Arduino, the problem is indeed with the bootloader on the ATmega328, not the firmware on the ATmega8U2. You’ll need an ISP (in-system programmer) like the AVRISP mkII or USBtinyISP to update the bootloader. If you don’t have one, you should just get a replacement board from the distributor you bought it from. There was only one batch that went out with the bootloader problem, so any new board should work fine.

Thanks very much hobbified and mellis… looks like I was chasing the wrong problem. I’ll pursue getting a replacement board.