Trouble interfacing Evil Mad Sci Relay Shield with a SEN-08630 ROHS PIR Sensor

I would like the relay shield I bought (Evil Mad Scientist Simple Relay Shield) to activate when the PIR sensor I bought senses motion. It seemed really simple, but I have a problem that I am guessing has to do with the hardware...here is a picture of my set up:

https://drive.google.com/file/d/0B7KzNOU57CVLZGpPdWhSNThfME0/view?usp=sharing

Blue LED connected to pin 8, green LED connected to a 9V battery and the relay. PIR sensor connected to pin 4.

When I use the shield, PIR, this code, and an LED, it works fine...led on for 3 seconds, wait 0.5 seconds and then look for the PIR to send a signal back to the Arduino.

int pirPin = 8; //digital 2
int LEDpin = 12;
int RelayPin = 4;

void setup(){
 Serial.begin(9600); 
 pinMode(pirPin, INPUT);
 pinMode(LEDpin, OUTPUT);
 pinMode(RelayPin, OUTPUT);
}


void loop(){
  int pirVal = digitalRead(pirPin);

  if(pirVal == LOW){ //was motion detected
    Serial.println("Motion Detected");
    digitalWrite(LEDpin, HIGH); 

    delay(2000);
    digitalWrite(LEDpin, LOW); 

    delay(500); 
  }

}

Video for just LED and PIR

but when I include the relay into the code, the relay and LED both start to blink in a loop like the PIR sensor isn't even attached.

int pirPin = 8; //digital 2
int LEDpin = 12;
int RelayPin = 4;

void setup(){
 Serial.begin(9600); 
 pinMode(pirPin, INPUT);
 pinMode(LEDpin, OUTPUT);
 pinMode(RelayPin, OUTPUT);
}


void loop(){
  int pirVal = digitalRead(pirPin);

  if(pirVal == LOW){ //was motion detected
    Serial.println("Motion Detected");
    digitalWrite(LEDpin, HIGH); 
    digitalWrite(RelayPin, HIGH); 
    delay(2000);
    digitalWrite(LEDpin, LOW); 
    digitalWrite(RelayPin, LOW);
    delay(500); 
  }

}

Video for PIR, LED, and Relay

It's like the PIR is getting some unintended voltage that messes with the sensor? I tried covering the PIR and it still blinks when attached when the relay is in the code. I hope this is enough info to get the idea across. I haven't posted before, I've just lurked, so please be merciful...any help is appreciated!

My apologies if this is in the wrong forum...let me know if this belongs elsewhere.