Trouble programming Nano with ICSP

I originally posted in troubleshooting, but this looks like a more relevant section so reposting here as I got no hints in the first one.

I'm trying to program Nano using ICSP. For that I use Pololu USB AVR Programmer v2.1.

Whenever I try flashing sketch or bootloader I always get en error which programmer utility describes as: " Error: Initial SPI command failed. The SPI command for entering programming mode was sent, but the expected response from the target was not received. Make sure that the ISP frequency is less than one sixth of the target's clock frequency. "

What I tried so far:

Verified that programmer works - burn arduino uno sketch with its own usb programmer/bootloader - burn arduino uno sketch with programmer via ICSP - burn arduino uno bootloader with programmer via ICSP

Verified that nano works - burn arduino nano sketch with its own usb programmer/bootloader

What fails - burning arduino nano either sketch or bootloader with ICSP

I checked the MISO signal on the header while trying to program and indeed to shows no activity which is inline with what programmer says. I tried lowering programmer frequency without much effect, but I don't think it is a problem here.

I'm I doing something wrong with Nano here? What else can I check or try?

In the grand scheme of things, I have two nano's and one has issues with bootloader which I want to fix by reflashing. The other nano is brand new and works fine beside not being able to program with ICSP.

I've deleted your cross post. In the future, if you need to have a post moved to a different forum section, please click the "Report to moderator" link on the post and request that it be moved.

Which “nano”?
These days there are some nano derivatives around that have an “avr compatible” cpu that doesn’t use isp.

One nano is a clone with Mega328P + PL2303 (the one that got slightly funny), another nano is a Arduino branded Mega328 + FTDI and came with all the box and papers from a trusted source.