Trouble uploading GRBL source code into the Arduino Uno

Hi, I’m having trouble compiling and uploading GRBL source code into the Arduino Uno IDE. I have downloaded GRBL from github and followed the online instructions. The grbl code shows up in the Arudino library folder but I keep getting a message when I try to compile and upload it saying:

Using library grbl in folder: C:\Users\user\Documents\Arduino\libraries\grbl (legacy)
exit status 1
Error compiling for board Arduino Uno.

The source code uploaded and worked fine the first time I followed the online instructions but I had to start from scratch again because I was having trouble with my CNC and I was unsure where the problem was coming from.

Does anybody have any suggestions?

Thank You.

Please post your full sketch.

If possible, you should always post code directly in the forum thread as text using code tags:

  • Do an Auto Format (Tools > Auto Format[/b) on your code. This will make it easier for you to spot bugs and make it easier for us to read.[/li]
  • - Edit > Copy for Forum*
  • - In a forum reply here, click on the reply field.*
    - Click the </> button on the forum toolbar. This will add the forum’s code tags markup to your reply.
  • - Press “Ctrl + V”. This will paste the sketch between the code tags.*
  • - Move the cursor outside of the code tags before you add any additional text to your reply.*
  • - Repeat the above process if your sketch has multiple tabs.*
  • [/list]*
  • This will make it easy for anyone to look at it, which will increase the likelihood of you getting help.*
  • If the sketch is longer than the 9000 characters maximum allowed by the forum, then it’s OK to add it as an attachment. After clicking the “Reply” button, you will see an “Attachments and other settings” link that will allow you to make the attachment.*
    When your code requires a library that’s not included with the Arduino IDE please post a link (using the chain links icon on the forum toolbar to make it clickable) to where you downloaded that library from or if you installed it using Library Manger (Sketch > Include Library > Manage Libraries in the Arduino IDE or Libraries > Library Manager in the Arduino Web Editor) then say so and state the full name of the library.

Do you know which version of GRBL you have that is causing the issue ?

This is the version I use.

Be aware that you may have to strip off the initial directory which may have the name "master"in it.
Best way is to simply move the inner folder out into the regular libraries then delete the empty master folder.

Also which IDE are you using ?

Could you also take a few moments to Learn How To Use The Forum.
Other general help and troubleshooting advice can be found here.
It will help you get the best out of the forum in the future.

@tjh100 reported via PM that they solved the problem.

Could we know HOW ?

Ya know just to assist others and all that good stuff.