Trouble uploading in Arduino UNO ( avrdude : ser_open () Can't Open Device.)

HI all,
I am using the Arduino Uno atmega328 R3 board. It has been working fine for days...
I was playing with Liquid Crystal library and have somehow gotten the board into a mode where I can't upload a new code.

I've tried to upload the basic code that is :-

void setup() {
  
}

void loop() {
 
}

but it still cannot upload.
I've Checked all the serial ports and updated the drivers and it all seems to be fine.
Oh! well I'm using Windows 7 Ultimate version of OS.
I've tried everything from changing USB cable to trying on another PC,but its still not working.
Can anyone please help?
Did I just Fry my board or anything?

Thanks in Advance for any help.

Try press & hold the Reset button. Start a download. When the IDE shows "Compiled xxx bytes of 32xxx bytes" release the reset button.
If you select File:preferences and turn on Verbose outputs, the timing of the release can be easier to find.

Thanks for the suggestion,

I tried doing that and I'm getting this output:-

Sketch uses 940 bytes (2%) of program storage space. Maximum is 32256 bytes.
Global variables use 9 bytes (0%) of dynamic memory, leaving 2039 bytes for local variables. Maximum is 2048 bytes.
C:\Program Files\Arduino\hardware\tools\avr/bin/avrdude -CC:\Program Files\Arduino\hardware\tools\avr/etc/avrdude.conf -v -patmega328p -carduino -PCOM1 -b115200 -D -Uflash:w:C:\Users\User\AppData\Local\Temp\arduino_build_365062/Testing.ino.hex:i
An error occurred while uploading the sketch

avrdude: Version 6.3, compiled on Dec 16 2016 at 13:33:19
Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
Copyright (c) 2007-2014 Joerg Wunsch

System wide configuration file is "C:\Program Files\Arduino\hardware\tools\avr/etc/avrdude.conf"

Using Port : COM1
Using Programmer : arduino
Overriding Baud Rate : 115200
I've Switched on only the upload verbose.
Should I on the compilation verbose also?